#5946 closed defect (invalid)

Lavfi & filter_complex ignore codec and pixel format

Reported by: LordHDL Owned by:
Priority: normal Component: avfilter
Version: git-master Keywords: overlay
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary: When using filtergraphs, the output video will default to yuva420p instead of being based on the codec chosen. If pixel format is manually specified, it will be reflected in the stream details but not in the actual output video.
How to reproduce: Use the -c:v and -pix_fmt commands after using -lavfi or -filter_complex.

ffmpeg -loop 1 -i ~/Desktop/FP2.tiff -i ~/Desktop/fp.mov -lavfi \
"[1:v]fps=60[video]; \
 [0:v][video]overlay=50:200:shortest=1[final]" \
-map "[final]" -map 1:a -c:v ffv1 -level 3 -c:a copy ~/Desktop/filtergraph.nut

Attachments (1)

filtergraph (8.6 KB) - added by LordHDL 19 months ago.

Download all attachments as: .zip

Change History (3)

Changed 19 months ago by LordHDL

comment:1 Changed 19 months ago by richardpl

This is because how overlay filter works and picks output pixel format by default.
There is an option to specify output pixel format for overlay filter.

comment:2 Changed 19 months ago by cehoyos

  • Keywords overlay added
  • Resolution set to invalid
  • Status changed from new to closed

The format option of the overlay filter including its default is documented.

Note: See TracTickets for help on using tickets.