Opened 3 years ago

Last modified 2 years ago

#5925 closed defect

Trying to transcode a mxf prores video file (spanned) to mov x264 — at Version 1

Reported by: dr_pardee Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: prores mxf
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description (last modified by cehoyos)

Summary of the bug:

With the Canon EOS C300, it spans clips. In our case, these clips are being ingested into Avid Media Composer and the video is encoded to ProRes?. Generally we transcode each part of the spanned clip and then concatenate the clips together to form one clip. However, with ProRes? in particular, the first clip of the spanned clips will transcode but the remaining clips will not.
I've tried explicitly specifying the format, the video codec, ffmbc, but I keep encountering: Output file #0 does not contain any stream

How to reproduce:

/home/pw/bin/ffmpeg -c:v:0 prores -r 23.98 -i /mnt/loadingdock_tc1/.A00001V01.D435447D_580FF66A060a2b340101010101010f0013000000580ff66a8f4e0162060e2b347f7f2a80.mxf -b:v 800k -maxrate 800k -s 320x240 -vcodec copy -y -threads 0 -report '/tmp/media/BZ0_MEDIA/LOCAL/BZ01020A01/2BZ01020A01-1.mov'
ffmpeg started on 2016-11-02 at 16:33:51
Report written to "ffmpeg-20161102-163351.log"
ffmpeg version N-82119-g1342339 Copyright (c) 2000-2016 the FFmpeg developers
  built with gcc 4.8 (Ubuntu 4.8.4-2ubuntu1~14.04.3)
  configuration: --prefix=/home/pw/ffmpeg_build --pkg-config-flags=--static --extra-cflags=-I/home/pw/ffmpeg_build/include --extra-ldflags=-L/home/pw/ffmpeg_build/lib --bindir=/home/pw/bin --enable-gpl --enable-libass --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-nonfree
  libavutil      55. 33.100 / 55. 33.100
  libavcodec     57. 63.103 / 57. 63.103
  libavformat    57. 55.100 / 57. 55.100
  libavdevice    57.  0.103 / 57.  0.103
  libavfilter     6. 64.100 /  6. 64.100
  libswscale      4.  1.100 /  4.  1.100
  libswresample   2.  2.100 /  2.  2.100
  libpostproc    54.  0.100 / 54.  0.100
[mxf @ 0x39c8fe0] invalid KAGSize 2097152 - guessing 1
[mxf @ 0x39c8fe0] material track 2: has 11 components
[mxf @ 0x39c8fe0] material track 3: has 11 components
[mxf @ 0x39c8fe0] material track 4: has 11 components
[mxf @ 0x39c8fe0] x >= nb_ptses - IndexEntryCount 7585 < IndexDuration 7584?
Input #0, mxf, from '/mnt/loadingdock_tc1/.A00001V01.D435447D_580FF66A060a2b340101010101010f0013000000580ff66a8f4e0162060e2b347f7f2a80.mxf':
  Metadata:
    project_name    : 2398_BALLERS
    uid             : ff420b2d-b7fa-e04f-a346-6e7a538f184a
    generation_uid  : b6bcfcab-70ff-7331-d7dc-925e69de11d2
    application_platform: AAFSDK (MacOS X)
    modification_date: 2016-10-26T00:22:40.000000Z
    product_uid     : acfbf03a-4f42-a231-d0b7-c06ecd3d4ad7
    product_version : Unknown version
    product_name    : Avid Media Composer 7.0.4.3735
    company_name    : Avid Technology, Inc.
    material_package_umid: 0x060A2B340101010101010F0013000000580FF66A8F4E0162060E2B347F7F2A80
    material_package_name: A00001.new.01
    comment__videobasename: CANON XF MPEG-2 422
    comment_CompanyName: CANON
    comment_Product : EOS C300
    comment_lastModifiedDate: 2012-05-20 19:14:34
    comment_TapeID  : BZ01020A01
  Duration: N/A, bitrate: N/A
    Stream #0:0: Data: none
    Metadata:
      file_package_umid: 0x060A2B340101010101010F0013000000580FF66A8F4F0162060E2B347F7F2A80
      track_name      : V1
      data_type       : video
    Stream #0:1: Data: none
    Metadata:
      file_package_umid: 0x060A2B340101010101010F0013000000580FF66A8F830162060E2B347F7F2A80
      track_name      : A1
      data_type       : audio
    Stream #0:2: Data: none
    Metadata:
      file_package_umid: 0x060A2B340101010101010F0013000000580FF66A8F8E0162060E2B347F7F2A80
      track_name      : A2
      data_type       : audio
Output #0, mov, to '/tmp/media/BZ0_MEDIA/LOCAL/BZ01020A01/2BZ01020A01-1.mov':

I have the full log/ouput of working first clip in spanned clips and the non-working clip.

Change History (3)

Changed 3 years ago by dr_pardee

First clip in spanned clips that does transcode

Changed 3 years ago by dr_pardee

2nd clip in spanned clip, not working

comment:1 Changed 3 years ago by cehoyos

  • Description modified (diff)

Please point us to a sample file.

Note: See TracTickets for help on using tickets.