Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5912 closed enhancement (duplicate)

teletext / zvbi -> dvbsub

Reported by: laursen Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi I would like to sponsor adding to ffmpeg encoding dvb_teletext (EN 300 472) into dvb_subtitles (EN 300 743).

Here is a sample file with DVB teletext subtitles:
http://samples.ffmpeg.org/ffmpeg-bugs/trac/ticket2086/teletextsubtitles.ts

There is 2 ways as faar as i can see :

1, Make libzvbi decode bitmaps the dvbsub encoder can take, or make the dvbsub encoder take the current zvbi bitmap output and make it into something that can be feed into the current dvbsub encoder.

From what i understand this is the problem :

ffmpeg -i ~/Downloads/teletextsubtitles.ts -acodec copy -vcodec copy
-scodec dvb_subtitle -y -f mpegts /dev/null
fails with message "Subtitle encoding failed". Problem is caused by
subtitle regions having 41 color in palette, which is too big for
supported modes in dvb_subtitle format.
Link : https://ffmpeg.org/pipermail/ffmpeg-devel/2014-January/153114.html

2, Make a rasterizer for the dvbsub and perhaps other subtitle encoders in ffmpeg, so the text based zvbi output can be feed into the dvbsub encoder.

I think method 2 would be a great addon to ffmpeg making it able convert text based subtitles into picture based it would help dvdsub encoder also. But it would also be fine with method 1.

I will provide more info and test files on request.

Change History (2)

comment:1 Changed 2 years ago by laursen

  • Resolution set to invalid
  • Status changed from new to closed

comment:2 Changed 2 years ago by cehoyos

  • Keywords zvbi -> dvbsub removed
  • Priority changed from important to normal
  • Resolution changed from invalid to duplicate
  • Type changed from sponsoring request to enhancement
Note: See TracTickets for help on using tickets.