Opened 12 months ago

Last modified 6 months ago

#5795 reopened defect

decoding with some pbm files

Reported by: jrun Owned by:
Priority: minor Component: avcodec
Version: git-master Keywords: pbm
Cc: darwinskernel@gmail.com Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

% ffmpeg -i 002.pbm -f null -

ffmpeg version

N-81451-g8a78fc5 Copyright (c) 2000-2016 the FFmpeg developers
built with gcc 4.9.3 (Gentoo 4.9.3 p1.5, pie-0.6.4)
configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64
--docdir=/usr/share/doc/ffmpeg-9999/html --mandir=/usr/share/man --enable-shared
--cc=x86_64-pc-linux-gnu-gcc --cxx=x86_64-pc-linux-gnu-g++
--ar=x86_64-pc-linux-gnu-ar --optflags='-O2 -pipe' --disable-static
--enable-avfilter --enable-avresample --disable-stripping --disable-indev=v4l2
--disable-outdev=v4l2 --disable-indev=oss --disable-indev=jack
--disable-outdev=oss --disable-outdev=sdl --enable-bzlib
--disable-runtime-cpudetect --disable-debug --disable-gcrypt --disable-gnutls
--disable-gmp --enable-gpl --enable-hardcoded-tables --enable-iconv
--disable-lzma --enable-network --disable-openssl --enable-postproc
--disable-libsmbclient --disable-ffplay --disable-sdl --disable-vaapi
--enable-vdpau --disable-xlib --enable-libxcb --enable-libxcb-shm
--enable-libxcb-xfixes --enable-zlib --disable-libcdio --disable-libiec61883
--disable-libdc1394 --disable-libcaca --disable-openal --enable-opengl
--disable-libv4l2 --disable-libpulse --disable-libopencore-amrwb
--disable-libopencore-amrnb --disable-libfdk-aac --disable-libopenjpeg
--disable-libbluray --disable-libcelt --disable-libgme --disable-libgsm
--disable-mmal --disable-libmodplug --enable-libopus --disable-libilbc
--disable-librtmp --disable-libssh --disable-libschroedinger --disable-libspeex
--disable-libvorbis --disable-libvpx --disable-libzvbi --disable-libbs2b
--disable-chromaprint --disable-libebur128 --disable-libflite --disable-frei0r
--disable-libfribidi --disable-fontconfig --disable-ladspa --disable-libass
--disable-libfreetype --disable-librubberband --enable-libzimg --disable-libsoxr
--enable-pthreads --disable-libvo-amrwbenc --disable-libmp3lame
--disable-libfaac --disable-libkvazaar --disable-nvenc --enable-libopenh264
--disable-libsnappy --disable-libtheora --disable-libtwolame
--disable-libwavpack --disable-libwebp --disable-libx264 --disable-libx265
--disable-libxvid --disable-amd3dnow --disable-amd3dnowext --disable-aesni
--disable-avx --disable-avx2 --disable-fma3 --disable-fma4 --disable-xop
--disable-doc --disable-htmlpages --enable-manpages

libavutil      55. 29.100 / 55. 29.100
libavcodec     57. 54.100 / 57. 54.100
libavformat    57. 48.100 / 57. 48.100
libavdevice    57.  0.102 / 57.  0.102
libavfilter     6. 54.100 /  6. 54.100
libavresample   3.  0.  0 /  3.  0.  0
libswscale      4.  1.100 /  4.  1.100
libswresample   2.  1.100 /  2.  1.100
libpostproc    54.  0.100 / 54.  0.100

built on:

Linux darkstar 4.7.0-hardened #1 SMP
Wed Aug 17 14:01:06 2016 x86_64 Intel(R) Core(TM) i3-2130 CPU @ 3.40GHz GenuineIntel
GNU/Linux

Attachments (4)

002.pbm (939.6 KB) - added by jrun 12 months ago.
ffmpeg-20160824-142434.log (4.8 KB) - added by jrun 12 months ago.
ffmpeg-20160824-164305.log (5.3 KB) - added by jrun 12 months ago.
patchinvalidpbm.diff (994 bytes) - added by cehoyos 12 months ago.

Download all attachments as: .zip

Change History (19)

Changed 12 months ago by jrun

Changed 12 months ago by jrun

comment:1 Changed 12 months ago by cehoyos

  • Component changed from avformat to undetermined
  • Keywords pnm pbm removed

Why does the console output you attached describe another file than the one you attached?
Which application shows an image for the file you attached?

comment:2 Changed 12 months ago by jrun

oops! my bad. attaching the right report.

Changed 12 months ago by jrun

comment:3 follow-up: Changed 12 months ago by cehoyos

Which application shows an image for the file you attached?

comment:4 in reply to: ↑ 3 Changed 12 months ago by jrun

Replying to cehoyos:

Which application shows an image for the file you attached?

sxiv
imv

comment:5 Changed 12 months ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords pbm added
  • Priority changed from normal to minor
  • Reproduced by developer set
  • Status changed from new to open
$ sxiv 002.pbm
sxiv: 002.pbm: Error opening image
sxiv: no more files to display, aborting

FreeImage reads the file though.

Changed 12 months ago by cehoyos

comment:6 Changed 12 months ago by cehoyos

Feel free to test attached patch.
How was your sample created? It seems like a bug to me that FreeImage reads the file, nothing else (including Netpbm) does afaict because the end of the file (that apparently only contains "0"s) is missing, around 400kB.

comment:7 Changed 12 months ago by jrun

if i crop the scanning area to the point that there is no black at the bottom, then ffmpeg is happy. trying the patch in a minute.

comment:8 Changed 12 months ago by cehoyos

The file you attached is produced by your scanner? Which scanner is this?

comment:9 Changed 12 months ago by jrun

this is what sane sees:

hpaio:/usb/HP_Officejet_Pro_X476dn_MFP

comment:10 Changed 12 months ago by jrun

works here. thanks.

comment:11 Changed 6 months ago by richardpl

  • Resolution set to wontfix
  • Status changed from open to closed

comment:12 Changed 6 months ago by cehoyos

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:13 Changed 6 months ago by richardpl

Why you reopened it if you can not fix it?

comment:14 Changed 6 months ago by richardpl

  • Resolution set to needs_more_info
  • Status changed from reopened to closed

comment:15 Changed 6 months ago by cehoyos

  • Resolution needs_more_info deleted
  • Status changed from closed to reopened
Note: See TracTickets for help on using tickets.