Opened 2 years ago

Closed 2 years ago

#5782 closed defect (duplicate)

Cannot play m4a files with mpd v0.19.18 but their dev team suspects the bug is with ffmpeg

Reported by: graysky Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
Mpd v0.19.18 no longer plays m4a encoded files. Here is the bug report made against mpd wherein one of their developers suspects that the bug reported lies with ffmpeg. The technical details are above my head so please see his or her comments in that report.

How to reproduce:
A free test file maybe obtained like so:
wget http://cdn.online-convert.com/example-file/audio/example.m4a

Playing with ffplay works as expected but playing from within mpd does not. The complete mpd.log is available at the link above but it essentially echos the following line thousands of times and does not play:

Aug 07 16:35 : ffmpeg: avcodec_send_packet() failed: Invalid data found when processing input

I attached here the output of ffmpeg -v 9 -loglevel 99 -i example.m4a per the directing webpage although I don't know what value it adds.

Attachments (1)

ffmpeg.log.gz (22.1 KB) - added by graysky 2 years ago.

Download all attachments as: .zip

Change History (2)

Changed 2 years ago by graysky

comment:1 Changed 2 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5781.

Note: See TracTickets for help on using tickets.