Opened 2 years ago

Closed 2 years ago

#5648 closed defect (fixed)

ffmpeg cannot recognize (get infomation of) width and hight of flv video stream

Reported by: orz- Owned by:
Priority: important Component: avformat
Version: git-master Keywords: flv regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
I am trying to transcode from flv(VP6+mp3) video to mp4(avc+aac-le) format,
with our(saccubus team) mod verison of ffmpeg in Windows OS(7 or 8.1 or 10).
I could transcode that kind of flv to mp4 older than n2.8 mod,
but I cannot transcode now with newer than n2.8.2 version of ffmpeg ,not only mod but also original ffmpeg(windows binary of https://ffmpeg.zeranoe.com/builds/).

How to reproduce:
My trial of latest version is (using mingw_w64-32-i686 + msys2)

% ffmpeg.exe -analyzeduration 30M -probesize 30M -y -i flv_width_hight_unrecognizable.flv -threads 0 -s 512x384 -acodec aac -ab 128k -ar 44100 -ac 2 -vcodec libx264 -crf 23 -b 1400k -bt 2000k -maxrate 2000k -bufsize 2000k -async 1 -coder 1 -sws_flags lanczos -flags +loop -cmp +chroma -partitions +parti4x4+partp8x8+partb8x8 -me_method umh -subq 8 -me_range 16 -g 250 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71 -b_strategy 2 -qcomp 0.6 -qmin 10 -qmax 51 -qdiff 4 -bf 3 -refs 3 -direct-pred auto -trellis 1 -weightp 1 -mixed-refs 1 -8x8dct 1 -fast-pskip 1 -pix_fmt yuv420p output.mp4

#ffmpeg version: 20160614-git-cb46b78-win32

Attachments (3)

ffmpeg-20160617-150616.log (158.0 KB) - added by orz- 2 years ago.
log file to trial of intended transcode flv to mp4
ffmpeg-20160617-155806.log (75.2 KB) - added by orz- 2 years ago.
loglevel 99
flv_width_hight_unrecognizable_cut.flv (2.4 MB) - added by cehoyos 2 years ago.

Change History (10)

Changed 2 years ago by orz-

log file to trial of intended transcode flv to mp4

Changed 2 years ago by orz-

loglevel 99

comment:1 Changed 2 years ago by cehoyos

  • Component changed from ffmpeg to undetermined

Where is the sample?
And where can I find your modified version of FFmpeg?

comment:2 Changed 2 years ago by orz-

The modified version of FFmpeg is here,
https://github.com/Saccubus/ffmpeg/tree/Saccubus1
build script mod
https://github.com/Saccubus/ffmpeg-windows-build-helpers/tree/saccubus
and other required software (to access video site via network)
but this dooes not relate to this problem I think.
https://github.com/Saccubus/Saccubus1.x

About the sample, I have not submitted yet,
since I cannot connect to ftp://upload.ffmpeg.org. (TIME-OUT always)
How can I upload?

comment:4 Changed 2 years ago by cehoyos

Our upload server is currently down, please use http://www.datafilehost.com/ or any other site that does not require a login.

comment:5 Changed 2 years ago by orz-

uploaded zip
https://www.datafilehost.com/d/1dbae64b
file name is ffmpeg_bug_ticket5648.zip

comment:6 Changed 2 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Regression since cbbd906be6150be38dfc14b6bc67dcac8da8aea4
Similar to ticket #4867 and #4903, this sample contains no encoder string though.

Last edited 2 years ago by cehoyos (previous) (diff)

Changed 2 years ago by cehoyos

comment:7 Changed 2 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.