Opened 2 years ago

Closed 2 years ago

#5638 closed defect (duplicate)

Commit ca2f19b9cc37be509d85 breaks videotoolbox decoding

Reported by: maru Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: h264 regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hello,

I recently updated my mpv build with an updated ffmpeg library version from HEAD and noticed that videotoolbox was no longer able to decode h.264 videos which were working fine before. I tracked this down to commit 8d0cc8ca97678f4ca "h264_parser: switch to h2645_parse for NAL unescaping". If I revert to a commit before that everything works, with this commit the initialisation of videotoolbox fails.
Sadly a simple revert of this commit is not possible so I could not check that.

Change History (4)

comment:1 Changed 2 years ago by cehoyos

  • Keywords h264 regression added
  • Priority changed from normal to important

comment:2 Changed 2 years ago by maru

Sorry I pasted the WRONG commit from my notes it IS commit

ca2f19b9cc37be509d85 "switch to h2645_parse for NAL parsing"

comment:3 Changed 2 years ago by maru

  • Summary changed from Commit 8d0cc8ca breaks videotoolbox decoding to Commit ca2f19b9cc37be509d85 breaks videotoolbox decoding

comment:4 Changed 2 years ago by kernrj

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5595 - fixed in 8e47a99f576d.

Note: See TracTickets for help on using tickets.