Opened 3 years ago

Closed 2 years ago

#5619 closed defect (invalid)

[nvenc_hevc @ 00000000032000a0] EncodePicture failed!

Reported by: DocMAX Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

% ffmpeg -i film1.mkv -c:v nvenc_hevc film2.mkv

ffmpeg version N-80219-g153ab83
built with gcc 5.3.0 (GCC)

i get

[nvenc_hevc @ 00000000032000a0] EncodePicture? failed!: generic error (20)
Video encoding failed
Conversion failed!

nvidia drivers 368.39

Change History (4)

comment:1 Changed 3 years ago by DocMAX

gfx card: geforce 970 gtx

comment:2 Changed 2 years ago by Klojum

A similar problem happens here, using a MSI GTX 950 Gaming 2GB:

ffmpeg -i "D:\Source\video.mkv" -vcodec nvenc_hevc -preset slow -acodec copy -sn "D:\Source\video.hevc"

ffmpeg version N-80522-ge0faad8 Copyright (c) 2000-2016 the FFmpeg developers

built with gcc 5.4.0 (GCC)

[nvenc_hevc @ 0000000002540540] EncodePicture? failed!: generic error (20)
Video encoding failed
Conversion failed!

Also Nvidia drivers 368.39, using Windows 10 Home.

Last edited 2 years ago by Klojum (previous) (diff)

comment:3 Changed 2 years ago by aotom

I fixed this by installing the CUDA 7.5 Toolkit.

I dont know what fixed it thats inside the toolkit because i installed everything. Even the old 353.90 drivers that were included.

But now i can use the nvenc_hevc vcodec.

comment:4 Changed 2 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.