Opened 2 years ago

Closed 8 days ago

Last modified 8 days ago

#5381 closed enhancement (fixed)

dxv: support "high quality" mode

Reported by: ami_stuff Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: dxv
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description (last modified by richardpl)

C:\>ffmpeg -i dxv_hq.mov -t 1 out.avi
ffmpeg version N-78758-g5156578 Copyright (c) 2000-2016 the FFmpeg developers
  built with gcc 5.3.0 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --
enable-libdcadec --enable-libfreetype --enable-libgme --enable-libgsm --enable-l
ibilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enab
le-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --en
able-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --ena
ble-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --
enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-lib
x265 --enable-libxavs --enable-libxvid --enable-libzimg --enable-lzma --enable-d
ecklink --enable-zlib
  libavutil      55. 19.100 / 55. 19.100
  libavcodec     57. 27.100 / 57. 27.100
  libavformat    57. 26.100 / 57. 26.100
  libavdevice    57.  0.101 / 57.  0.101
  libavfilter     6. 37.100 /  6. 37.100
  libswscale      4.  0.100 /  4.  0.100
  libswresample   2.  0.101 /  2.  0.101
  libpostproc    54.  0.100 / 54.  0.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'dxv_hq.mov':
  Metadata:
    major_brand     : qt
    minor_version   : 537199360
    compatible_brands: qt
    creation_time   : 2016-01-05 17:17:55
  Duration: 00:00:18.29, start: 0.000000, bitrate: 10029 kb/s
    Stream #0:0(eng): Video: dxv (DXD3 / 0x33445844), rgba, 333x333, 14458 kb/s,
 23.97 fps, 23.98 tbr, 600 tbn, 600 tbc (default)
    Metadata:
      creation_time   : 2016-01-05 17:17:55
      handler_name    : Procedura obs|ugi skr'<t'<w danych Apple
      encoder         : DXV 3
Output #0, avi, to 'out.avi':
  Metadata:
    major_brand     : qt
    minor_version   : 537199360
    compatible_brands: qt
    ISFT            : Lavf57.26.100
    Stream #0:0(eng): Video: mpeg4 (FMP4 / 0x34504D46), yuv420p, 333x333, q=2-31
, 200 kb/s, 23.98 fps, 23.98 tbn, 23.98 tbc (default)
    Metadata:
      creation_time   : 2016-01-05 17:17:55
      handler_name    : Procedura obs|ugi skr'<t'<w danych Apple
      encoder         : Lavc57.27.100 mpeg4
    Side data:
      cpb: bitrate max/min/avg: 0/0/200000 buffer size: 0 vbv_delay: -1
Stream mapping:
  Stream #0:0 -> #0:0 (dxv (native) -> mpeg4 (native))
Press [q] to stop, [?] for help
[dxv @ 03920740] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03921880] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03922240] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 039235c0] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03924920] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

[dxv @ 03920e40] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03923f80] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03920740] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

[dxv @ 039252e0] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

[dxv @ 03920e40] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

[dxv @ 03921880] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03922240] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03922c00] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

    Last message repeated 1 times
[dxv @ 03922c00] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 039235c0] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

    Last message repeated 1 times
[dxv @ 03923f80] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03924920] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

    Last message repeated 1 times
[dxv @ 039252e0] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03920740] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

    Last message repeated 1 times
[dxv @ 03920e40] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03921880] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

    Last message repeated 1 times
[dxv @ 03922240] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03922c00] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

    Last message repeated 1 times
[dxv @ 039235c0] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03923f80] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

    Last message repeated 1 times
[dxv @ 03924920] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 039252e0] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

    Last message repeated 1 times
[dxv @ 03920740] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03920e40] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome


    Last message repeated 1 times
[dxv @ 03922240] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03922c00] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

    Last message repeated 1 times
[dxv @ 039235c0] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
[dxv @ 03923f80] Tag 0x59434736 is not implemented. Update your FFmpeg version t
o the newest one from Git. If the problem still occurs, it means that your file
has a feature which has not been implemented.
Error while decoding stream #0:0: Not yet implemented in FFmpeg, patches welcome

    Last message repeated 1 times
frame=    0 fps=0.0 q=0.0 Lsize=       6kB time=00:00:00.00 bitrate=N/A speed=
 0x
video:0kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing ove
rhead: unknown
Output file is empty, nothing was encoded (check -ss / -t / -frames parameters i
f used)
Conversion failed!

Change History (21)

comment:2 Changed 2 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords dxv added
  • Priority changed from normal to wish
  • Reproduced by developer set
  • Status changed from new to open
  • Type changed from defect to enhancement
  • Version changed from unspecified to git-master

comment:3 Changed 11 days ago by richardpl

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from open to closed

comment:4 Changed 11 days ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

Unfortunately, the committed patch is not a 100% fix.

comment:5 Changed 8 days ago by richardpl

  • Resolution set to fixed
  • Status changed from reopened to closed

F O.

comment:6 Changed 8 days ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

?

comment:7 Changed 8 days ago by richardpl

  • Resolution set to fixed
  • Status changed from reopened to closed

Grow up, you little nuisance.

comment:8 Changed 8 days ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

The samples do not look correct here...

comment:9 Changed 8 days ago by atomnuker

  • Resolution set to fixed
  • Status changed from reopened to closed

They'll look correct if you view them with something capable of displaying or converting YCoCg colorspace. They decode correctly so issue should be closed. Feel free to open another issue about displaying and converting YCoCg colorspaces in libswscale. Btw vf_colorspace supports converting them already.

comment:10 Changed 8 days ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

But it does not work with default FFmpeg so there still is an issue.

comment:11 Changed 8 days ago by cehoyos

Adding a duplicate filter was of course much worse than adding a few lines of duplicated code fwiw.

comment:12 Changed 8 days ago by atomnuker

  • Resolution set to fixed
  • Status changed from reopened to closed

We're not going to colorspace conversions inside decoders, and that's the end of it. Use the colorspace filter and please stop reopening this bug, since its about decoding.

comment:13 follow-up: Changed 8 days ago by gjdfgh

@cehoyos: please keep in mind that making an edit war will get you banned eventually.

comment:14 Changed 8 days ago by richardpl

Doing colorspace conversion with dumbest solution that reference decoder does give awful looking files.
So doing ycgo->rgba conversion in decoder is not solution.

comment:15 Changed 8 days ago by heleppkes

A key fact to remember is that the missing link here is entirely unrelated to dxv, as mentioned on the ML on this topic before, you could get a H264 file with YCoCg and get the same issue, should we be creating trac tickets for all of those, or just one that YCoCg -> RGB conversion is missing?

Its not a codec-related problem anymore, so this issue can be considered resolved.

comment:16 Changed 8 days ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:17 in reply to: ↑ 13 Changed 8 days ago by cehoyos

Replying to gjdfgh:

@cehoyos: please keep in mind that making an edit war will get you banned eventually.

On the mailing list, I cannot stop you from breaking rules you requested, do not threaten people here!

comment:18 Changed 8 days ago by richardpl

  • Resolution set to fixed
  • Status changed from reopened to closed

I'm officially requesting that @cehoyos is banned from our project.

comment:19 Changed 8 days ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

Please either open a new ticket or leave this one open.

comment:20 Changed 8 days ago by richardpl

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:21 Changed 8 days ago by gjdfgh

Can you stop this edit war? You're behaving worse than children.

This bug definitely belongs closed though, since the decoder thing was definitely implemented. What cehoyos laments is apparently libswscale ycgco support, and he does it in a completely unacceptable manner.

I'm officially requesting that @cehoyos is banned from our project.

Wouldn't mind to be honest. As a victim of cehoyos' intense harassment I can only agree to this. Also in general it's probably better to remove toxic elements from open source projects. In particular, bad behavior should have consequences, or it'll go on forever.

On the mailing list, I cannot stop you from breaking rules you requested, do not threaten people here!

This is slander. Can you stop harassing me all the time?

Note: See TracTickets for help on using tickets.