Opened 3 years ago

Closed 3 years ago

#5247 closed defect (fixed)

Commit 470bfab470893d45328f4e6e25d60b89c9af1abe break --enable-x11grab

Reported by: telperion Owned by:
Priority: normal Component: build system
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Commit 470bfab470893d45328f4e6e25d60b89c9af1abe
break --enable-x11grab (x11grab cannot be enabled) on Debian x86_64

http://git.videolan.org/?p=ffmpeg.git;a=commit;h=470bfab470893d45328f4e6e25d60b89c9af1abe

mc@debian64:~/rec/temp/ffmpeg2-0$ git branch test 470bfab470893d45328f4e6e25d60b89c9af1abe
mc@debian64:~/rec/temp/ffmpeg2-0$ git checkout test
Si è passati al branch 'test'

mc@debian64:~/rec/temp/ffmpeg2-0$ ./configure  --enable-x11grab --enable-gpl
x11grab cannot be enabled

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solve the problem.

config.log:

check_pkg_config xcb >= 1.4 xcb/xcb.h xcb_connect
pkg-config --exists --print-errors xcb >= 1.4
check_func_headers xcb/xcb.h xcb_connect -lxcb
check_ld cc -lxcb
check_cc
BEGIN /tmp/ffconf.fC7Vyz50.c
    1	#include <xcb/xcb.h>
    2	long check_xcb_connect(void) { return (long) xcb_connect; }
    3	int main(void) { return 0; }
END /tmp/ffconf.fC7Vyz50.c
gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -std=c99 -fomit-frame-pointer -pthread -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/SDL -c -o /tmp/ffconf.Yb7jGpv4.o /tmp/ffconf.fC7Vyz50.c
gcc -Wl,--as-needed -Wl,-z,noexecstack -o /tmp/ffconf.34aEOZpM /tmp/ffconf.Yb7jGpv4.o -lxcb -lX11 -ljack -lasound -lSDL -lm -llzma -lbz2 -lz -pthread
x11grab cannot be enabled

before:

mc@debian64:~/rec/temp/ffmpeg2-0$ git checkout master
Si è passati al branch 'master'
Your branch is up-to-date with 'origin/master'.
mc@debian64:~/rec/temp/ffmpeg2-0$ git branch -d test
Ramo test eliminato (era 470bfab).

mc@debian64:~/rec/temp/ffmpeg2-0$ git branch test f97ee815cf25580cbb9d6bed304d9c22895f7074
mc@debian64:~/rec/temp/ffmpeg2-0$ git checkout test
Si è passati al branch 'test

mc@debian64:~/rec/temp/ffmpeg2-0$ ./configure  --enable-x11grab --enable-gpl
...
License: GPL version 2 or later
Creating config.mak, config.h, and doc/config.texi...
config.h is unchanged
config.asm is unchanged
libavutil/avconfig.h is unchanged
mc@debian64:~/rec/temp/ffmpeg2-0$ 

Change History (2)

comment:2 Changed 3 years ago by heleppkes

  • Resolution set to fixed
  • Status changed from new to closed

Indeed, the change has been reverted since its proven to be somewhat troublesome with no obvious clear fix for now.

Note: See TracTickets for help on using tickets.