Opened 3 years ago

Closed 3 years ago

#5200 closed defect (duplicate)

gif encoder: support transparency

Reported by: Colorama Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: alpha
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

the output gif file from "ffmpeg -i go.mov -pix_fmt pal8 go.gif" conversion is not transparent.

A:\>ffmpeg -i go.mov
ffmpeg version N-77085-g21fbc41 Copyright (c) 2000-2015 the FFmpeg developers
  built with gcc 5.2.0 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable
-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libbs2b
 --enable-libcaca --enable-libdcadec --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --e
nable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpe
g --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libth
eora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis
--enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enab
le-libxvid --enable-libzimg --enable-lzma --enable-decklink --enable-zlib
  libavutil      55. 10.100 / 55. 10.100
  libavcodec     57. 16.101 / 57. 16.101
  libavformat    57. 19.100 / 57. 19.100
  libavdevice    57.  0.100 / 57.  0.100
  libavfilter     6. 20.100 /  6. 20.100
  libswscale      4.  0.100 /  4.  0.100
  libswresample   2.  0.101 /  2.  0.101
  libpostproc    54.  0.100 / 54.  0.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'go.mov':
  Metadata:
    major_brand     : qt
    minor_version   : 537199360
    compatible_brands: qt
    creation_time   : 2016-01-28 11:29:10
  Duration: 00:00:02.00, start: 0.000000, bitrate: 791 kb/s
    Stream #0:0(eng): Video: qtrle (rle  / 0x20656C72), bgra, 200x200, 764 kb/s, SAR 1:1 DAR 1:1, 25 fps, 25 t
br, 25 tbn, 25 tbc (default)
    Metadata:
      creation_time   : 2016-01-28 11:29:11
      handler_name    : ╬сЁрсюЄўшъ яёхтфюэшьют Apple
      encoder         : ┬┐├М├Л├ПтАб╦Ж├Л╦З
      timecode        : 00:00:00:00
    Stream #0:1(eng): Data: none (tmcd / 0x64636D74), 0 kb/s (default)
    Metadata:
      creation_time   : 2016-01-28 11:29:12
      handler_name    : ╬сЁрсюЄўшъ яёхтфюэшьют Apple
      timecode        : 00:00:00:00
At least one output file must be specified

Attachments (1)

go.mov (193.3 KB) - added by Colorama 3 years ago.

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by Colorama

comment:1 Changed 3 years ago by cehoyos

  • Component changed from avcodec to undetermined
  • Keywords alpha added
  • Priority changed from important to normal
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version set to unspecified

For future tickets: Please always provide the command line that allows to reproduce the issue together with the complete, uncut console output.

Duplicate of ticket #4443.

Note: See TracTickets for help on using tickets.