Opened 3 years ago

Closed 2 years ago

#5167 closed defect (invalid)

rtsp: Invalid data found when processing input

Reported by: sivaprasanna Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: rtsp
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I'm trying to access an RTSP livestream using ffplay. I'm using the following command

ffplay "rtsp://qa.vibrnet.com:80/img/video.sav?MAC=00C0021F1116&channel=2&GUID=betaUser"

But I get an error saying "Invalid data found when processing the input". I tried debugging and this is what I got.

  ffplay version N-77816-g9ca64c3 Copyright (c) 2003-2016 the FFmpeg developers
  built with gcc 5.2.0 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --
enable-libdcadec --enable-libfreetype --enable-libgme --enable-libgsm --enable-l
ibilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enab
le-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --en
able-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --ena
ble-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc
 --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enabl
e-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-libzimg --
enable-lzma --enable-decklink --enable-zlib
  libavutil      55. 13.100 / 55. 13.100
  libavcodec     57. 22.100 / 57. 22.100
  libavformat    57. 21.101 / 57. 21.101
  libavdevice    57.  0.100 / 57.  0.100
  libavfilter     6. 23.100 /  6. 23.100
  libswscale      4.  0.100 /  4.  0.100
  libswresample   2.  0.101 /  2.  0.101
  libpostproc    54.  0.100 / 54.  0.100
rtsp://qa.vibrnet.com:80/img/video.sav?MAC=00C0021F1116&channel=2&GUID=betaUser: Invalid data found when processing input
    nan    :  0.000 fd=   0 aq=    0KB vq=    0KB sq=    0B f=0/0

Change History (15)

comment:1 Changed 3 years ago by cehoyos

  • Component changed from ffplay to undetermined
  • Keywords error ffmpeg ffplay invalid data streaming removed
  • Priority changed from important to normal
  • Summary changed from Invalid data found when processing input to rtsp: Invalid data found when processing input

Is the issue only reproducible with ffplay or also with ffmpeg -i input -qscale 2 out.avi?

$ host qa.vibrnet.com
Host qa.vibrnet.com not found: 3(NXDOMAIN)

How can I reproduce the issue?
Which application plays the stream?

comment:2 follow-up: Changed 3 years ago by sivaprasanna

This issue is also with ffmpeg. I tried to save the livestream to a local file. I got the same error. I tried using -loglevel debug, but still the same issue. This is the console output that I got when I tried with debug mode.

D:\..>ffmpeg -loglevel debug -i "rtsp://qa.vibrnet.com:80/img/video.sav?MAC=00C0021F1116&channel=2&GUID=betaUser" c:/video.mp4

ffmpeg version N-77816-g9ca64c3 Copyright (c) 2000-2016 the FFmpeg developers
  built with gcc 5.2.0 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --
enable-libdcadec --enable-libfreetype --enable-libgme --enable-libgsm --enable-l
ibilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enab
le-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --en
able-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --ena
ble-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc
 --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enabl
e-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-libzimg --
enable-lzma --enable-decklink --enable-zlib
  libavutil      55. 13.100 / 55. 13.100
  libavcodec     57. 22.100 / 57. 22.100
  libavformat    57. 21.101 / 57. 21.101
  libavdevice    57.  0.100 / 57.  0.100
  libavfilter     6. 23.100 /  6. 23.100
  libswscale      4.  0.100 /  4.  0.100
  libswresample   2.  0.101 /  2.  0.101
  libpostproc    54.  0.100 / 54.  0.100
Splitting the commandline.
Reading option '-loglevel' ... matched as option 'loglevel' (set logging level)
with argument 'debug'.
Reading option '-i' ... matched as input file with argument 'rtsp://qa.vibrnet.com:80/img/video.sav?MAC=00C0021F1116&channel=2&GUID=betaUser'.
Reading option 'c:/video.mp4' ... matched as output file.
Finished splitting the commandline.
Parsing a group of options: global .
Applying option loglevel (set logging level) with argument debug.
Successfully parsed a group of options.
Parsing a group of options: input file rtsp://qa.vibrnet.com:80/img/video.sav?MAC=00C0021F1116&channel=2&GUID=betaUser.
Successfully parsed a group of options.
Opening an input file: rtsp://qa.vibrnet.com:80/img/video.sav?MAC=00C0021F1116&channel=2&GUID=betaUser.

rtsp://qa.vibrnet.com:80/img/video.sav?MAC=00C0021F1116&channel=2&GUID=betaUser: Invalid data found when processing input

And host was not found because you can't access the link. The stream is available internally(within our local network) for testing purposes.

comment:3 in reply to: ↑ 2 Changed 3 years ago by cehoyos

Replying to sivaprasanna:

And host was not found because you can't access the link. The stream is available internally(within our local network) for testing purposes.

So how can I reproduce the issue?

comment:4 Changed 3 years ago by sivaprasanna

I'm sorry I don't know. :/ Maybe you can help me troubleshoot this issue? So that I'll try that and report back?

comment:5 Changed 3 years ago by cehoyos

Where in the code does the command fail currently?

comment:6 Changed 3 years ago by sivaprasanna

Since I've just began to work on this, I haven't written any code so far. I'm just playing around ffplay and ffmpeg. My first command was to play the livestream. I used

 ffplay "rtsp://qa.vibrnet.com:80/img/video.sav?MAC=00C0021F1116&channel=2&GUID=betaUser"

It failed then and there. Later just to check whether the issue persists with ffmpeg, I used the following

ffmpeg -i "rtsp://qa.vibrnet.com:80/img/video.sav?MAC=00C0021F1116&channel=2&GUID=betaUser" -f mp4 c:/video.mp4

Again it failed. First, I want to get this simple command working so that I can start writing code to encode the stream with .h264.

Edit: Just to check, can you please try executing this $ host videoqa.alarmnet.com. This one is for another product of us. It also uses a livestream with similar architecture and tech behind it. If that works, I can ask my colleagues to get that rtsp url and give it to you.

Last edited 3 years ago by sivaprasanna (previous) (diff)

comment:7 follow-up: Changed 3 years ago by cehoyos

Where in the FFmpeg code does the command fail currently?

comment:8 in reply to: ↑ 7 Changed 3 years ago by sivaprasanna

Replying to cehoyos:

Where in the FFmpeg code does the command fail currently?

Sorry, but I don't quite understand what you're saying.

comment:9 Changed 3 years ago by cehoyos

You asked above:

Maybe you can help me troubleshoot this issue?

FFmpeg currently returns "Invalid data found when processing input" for your input which corresponds to a return AVERROR_INVALIDDATA;. Where in the FFmpeg source code is this return triggered?

If you can provide to provide a command line that allows me to reproduce the issue, I will try to find out where it fails.

comment:10 Changed 3 years ago by sivaprasanna

FFmpeg source code? I'm sorry I don't know about that. I just downloaded the build from here http://ffmpeg.zeranoe.com/builds/ And I'm using Windows build, if that is of any help. Thank you!

comment:11 Changed 2 years ago by sivaprasanna

What do you mean by FFmpeg source code? I just downloaded the windows static build from the link provided in my previous post.

comment:12 Changed 2 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please feel free to reopen this ticket if you can either debug the issue yourself (you have to be able to compile FFmpeg yourself to do this) or if you can provide a command line that allows a developer to reproduce the issue.

comment:13 Changed 2 years ago by sivaprasanna

Okay. I just found this working live stream link. It is not rtsp though, but this stream also doesn't work with ffplay and ffmpeg. It also throws the same "Invalid data found when processing input error". You can try out the following command.

ffplay "http://melon.inlive.co.kr/listen.asx"

I also tried the url with ffmpeg. I get the same "Invalid data"error. Check out the below command.

ffmpeg -i "http://melon.inlive.co.kr/listen.asx" -f mp4 c:/video.mp4
Last edited 2 years ago by sivaprasanna (previous) (diff)

comment:14 Changed 2 years ago by sivaprasanna

  • Resolution needs_more_info deleted
  • Status changed from closed to reopened

comment:15 Changed 2 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.