Opened 3 years ago

Closed 3 years ago

#5106 closed defect (fixed)

Wrong tbr(fps) in mp4 and ogg output from input flv with 31 tbr(fps) and higher

Reported by: uzgraph Owned by:
Priority: important Component: avformat
Version: git-master Keywords: flv fps regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
Conversion of flv with fps of 31 and higher to mp4 and ogg thru the command line
ffmpeg -i filename.flv -b:v 1500k filename.mp4
result mp4 with tbr 0.08
and ffmpeg -i filename.flv -b:v 1500k filename.ogg
result ogg with tbr 1000.00
ffmpeg version N-71403-g415f1fa built with gcc 4.9.2
PS. Fixed by adding in command line: "-r 25" but it's wicked

Attachments (4)

ffmpeg-20151224-113122.log (1.1 MB) - added by uzgraph 3 years ago.
ffmpeg-20151224-113257.log (42.3 KB) - added by uzgraph 3 years ago.
appendicitis-1.flv (2.2 MB) - added by uzgraph 3 years ago.
bugconvert.bat (176 bytes) - added by uzgraph 3 years ago.

Change History (8)

comment:1 Changed 3 years ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords tbr/fps error removed

Please provide the command line that allows to reproduce this issue together with the complete, uncut console output to make this a valid ticket and please provide your input sample.

Changed 3 years ago by uzgraph

Changed 3 years ago by uzgraph

Changed 3 years ago by uzgraph

Changed 3 years ago by uzgraph

comment:2 Changed 3 years ago by uzgraph

Added:

  • Command lines in bugconvert.bat
  • Log files
  • flv sample

comment:3 Changed 3 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords flv fps regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Regression since 367c9d33 related to ticket #4012.

comment:4 Changed 3 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.