Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#5089 closed defect (invalid)

AC EOB marker is absent in MXF DV

Reported by: gausss Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: mxf dvvideo
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

The decoding for some MXF DV file results in multiple AC EOB marker is absent errors. The decoding error is visible in the output results in the form of colored squares and frames jumping. The attached file is a cut of the first 10 mb of the original file.
How to reproduce:

% ffmpeg -i input output.mp4
ffmpeg version N-75794-gd1c8368
built on  gcc 5.2.0 for windows 64 bit, static lib.

Attachments (1)

xaa1.mxf (1.4 MB) - added by gausss 3 years ago.

Download all attachments as: .zip

Change History (10)

Changed 3 years ago by gausss

comment:1 follow-up: Changed 3 years ago by gausss

The attached file is a cut of the original file, cutted with ffmpeg itself.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 3 years ago by cehoyos

Replying to gausss:

The attached file is a cut of the original file, cutted with ffmpeg itself.

Please provide a cut of the original file made with dd (or the whole original file) do not cut files with FFmpeg.

comment:3 Changed 3 years ago by cehoyos

  • Keywords mxf dvvideo added; Concealing bitstream errors AC EOB marker is absent removed

comment:4 Changed 3 years ago by gausss

Sorry, I attached the byte-cut of the first 11 MB.
Please referr to the 4 pieces disk1 7zip attachment.
I add that the "AC EOB marker is absent" seems not to be the cause of the problem, but between second 2nd and 3rd, another error pops out.
Tested with the latest ffmpeg build version N-77234-g906c0b7:

[mxf @ 00000029ddfaab40] OPAtom misinterpreted as OP1a? KLV for edit unit 59 extending into next edit unit is not implemented. Update your FFmpeg vers
ion to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
[mxf @ 00000029ddfaab40] If you want to help, upload a sample of this file to ftp://upload.ffmpeg.org/incoming/ and contact the ffmpeg-devel mailing l
ist. (ffmpeg-devel@ffmpeg.org)
[dvvideo @ 00000029de07eb40] could not find dv frame profile
Error while decoding stream #0:0: Error number -1 occurred
Last edited 3 years ago by gausss (previous) (diff)

comment:5 in reply to: ↑ 2 Changed 3 years ago by gausss

Replying to cehoyos:

Replying to gausss:

The attached file is a cut of the original file, cutted with ffmpeg itself.

Please provide a cut of the original file made with dd (or the whole original file) do not cut files with FFmpeg.

I've added disk1.7z attachment, that is a byte-cut of the first 11MB. thanks

comment:6 Changed 3 years ago by cehoyos

Which player does not show artefacts for disk1.mxf uploaded to http://samples.ffmpeg.org/ffmpeg-bugs/trac/ticket5089/ ?

comment:7 Changed 3 years ago by gausss

I've tested the file in VLC, and with mainconcept codecs; it shows artifacts also with this players.
At this point the file seems corrupted.
If I try to transcode the entire file (2.1GB MXF) I get a 100GB h.264 file full of timecode jumps!
Since I can't upload the entire file, and given that the file seems corrupted I close the ticket.
Thanks for support.

comment:8 Changed 3 years ago by gausss

  • Resolution set to invalid
  • Status changed from new to closed

comment:9 Changed 3 years ago by cehoyos

There is no file size limit for the FTP server, you pasted the address above...

Note: See TracTickets for help on using tickets.