Opened 2 years ago

Closed 2 years ago

#5040 closed defect (invalid)

concat inpoint outpoint results in unknown keyword

Reported by: secondplace Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
when a external file is loaded to merge files the syntax 'inpoint' and 'outpoint' are not recognized by ffmpeg.
How to reproduce:

create an external concat txt file:

file 'C:\file_%04d.tif'
duration 00:00:04.080
inpoint 00:00:02.000
outpoint 00:00:03.000

load it in ffmpeg:

ffmpeg -i "input.txt" ...

following error pops up:

[concat @ 000000000466d780] Line 2: unknown keyword 'inpoint'
input.txt: Invalid data found when processing input

Change History (6)

comment:1 Changed 2 years ago by secondplace

ups... input is...

ffmpeg -f concat -i "input.txt" ...

... of course

comment:2 Changed 2 years ago by Cigaes

Please provide the full output of ffmpeg, not just the last two lines.

comment:3 follow-up: Changed 2 years ago by secondplace

ffmpeg stops right away because of the input error, there is not more. it's a zeranoe build if that helps

"ffmpeg.exe" -f concat -i "D:\work\ffmpeg_concat_test.txt" ...  "D:\work\ffmpeg_concat_test.mp4"
ffmpeg version N-71633-gcbe2700 Copyright (c) 2000-2015 the FFmpeg developers
  built with gcc 4.9.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --
enable-libdcadec --enable-libfreetype --enable-libgme --enable-libgsm --enable-l
ibilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enab
le-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --en
able-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --ena
ble-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc
 --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enabl
e-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-lzma --ena
ble-decklink --enable-zlib
  libavutil      54. 23.101 / 54. 23.101
  libavcodec     56. 35.101 / 56. 35.101
  libavformat    56. 31.100 / 56. 31.100
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 14.100 /  5. 14.100
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  3.100 / 53.  3.100
[concat @ 000000000467d780] Line 3: unknown keyword 'inpoint'
D:\work\ffmpeg_concat_test.txt: Invalid data found when processing input

there is no documentation on how to use the concat syntaxes. i just might use the 'inpoint' syntax wrong in the script file.

Last edited 2 years ago by secondplace (previous) (diff)

comment:4 in reply to: ↑ 3 Changed 2 years ago by Cigaes

Replying to secondplace:

ffmpeg stops right away because of the input error, there is not more.


Yes, but there was output before the error, and that is what I wanted to see:

ffmpeg version N-71633-gcbe2700 Copyright (c) 2000-2015 the FFmpeg developers

(although the rest of the output would have been useful if my guess had been wrong)

Version N-71633-gcbe2700 dates back from 2015-04-22, inpoint/outpoint were implemented in July. You just need to upgrade.

comment:5 Changed 2 years ago by secondplace

lol i tried everything but to update :-D

glad the easiest solution solved the problem.
everything works as expected now

thanks very much

comment:6 Changed 2 years ago by cehoyos

  • Keywords concat inpoin outpoint merge concatenate concatenating removed
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.