Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4999 closed defect (duplicate)

Duplicate

Reported by: Den-ffmpeg Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi! I am trying to work with GoPro? videos made by Ambarella AVC. I tried to convert any video from that camera and output video was lagging.

The problem is old, it was reproduced in version 2.8.1 and has been existing at least from version 2.2.4

Input and output videos are attached.

How to reproduce:

ffmpeg -i "D:\videos\h264_gopro_ambarella.mp4" -vcodec h264 "D:\videos\lags_on_output_video.avi"
ffmpeg version 2.8.1 Copyright (c) 2000-2015 the FFmpeg developers
  built with gcc 5.2.0 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libbs2b
 --enable-libcaca --enable-libdcadec --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpe
g --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis
--enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-lzma --enable-decklink --enable-zlib
  libavutil      54. 31.100 / 54. 31.100
  libavcodec     56. 60.100 / 56. 60.100
  libavformat    56. 40.101 / 56. 40.101
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 40.101 /  5. 40.101
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  2.101 /  1.  2.101
  libpostproc    53.  3.100 / 53.  3.100

PS if you try to convert input file (h264_gopro_ambarella.mp4), you will see some errors in console output. It appeared after I reduced the size of file to 10 MB. If needed I will send you original file (about 25 MB)

Change History (2)

comment:1 Changed 3 years ago by Den-ffmpeg

Sorry for duplicating, I thought the size of attached file must be less than 10 MB according to http://ffmpeg.org/bugreports.html, but it was smaller during creation ticket. So I got error, but ticket had been already created :(

Last edited 3 years ago by Den-ffmpeg (previous) (diff)

comment:2 Changed 3 years ago by Den-ffmpeg

  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Skipping frames for GoPro videos recorder with Ambarella to Duplicate
Note: See TracTickets for help on using tickets.