Opened 4 years ago

Closed 4 years ago

#4851 closed defect (fixed)

avi regression

Reported by: genio Owned by:
Priority: important Component: avformat
Version: git-master Keywords: avi regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

I have an IP Camera from Huacam.com. That camera generates an AVI on motion detection and uploads that video to my FTP server. https://www.cwhitener.com/2015-09-14t12.47.26.avi can be used as an example of the error-proned video files.

I then attempt to turn that AVI into an MP4 and WEBM video later, but none of the files after the AVI like to run anywhere. VLC will play the AVI.

How to reproduce:

% ffmpeg -i 2015-09-14t12.47.26.avi -an -vcodec copy -movflags faststart output.mp4
% ffmpeg -i 2015-09-14t12.47.26.avi -c:v libvpx -minrate 1M -maxrate 1M -b:v 1M -an output.webm

$ /home/camuser/bin/ffmpeg -version
ffmpeg version N-43556-gca00dda Copyright (c) 2000-2015 the FFmpeg developers
built with gcc 4.8.3 (GCC) 20140911 (Red Hat 4.8.3-9)
configuration: --prefix=/home/cwhitener/ffmpeg_build --extra-cflags=-I/home/cwhitener/ffmpeg_build/include --extra-ldflags=-L/home/cwhitener/ffmpeg_build/lib --bindir=/home/cwhitener/bin --pkg-config-flags=--static --enable-gpl --enable-nonfree --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265
libavutil      55.  2.100 / 55.  2.100
libavcodec     57.  1.100 / 57.  1.100
libavformat    57.  0.100 / 57.  0.100
libavdevice    57.  0.100 / 57.  0.100
libavfilter     6.  3.100 /  6.  3.100
libswscale      4.  0.100 /  4.  0.100
libswresample   2.  0.100 /  2.  0.100
libpostproc    54.  0.100 / 54.  0.100

on CentOS 7

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Change History (2)

comment:1 Changed 4 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords avi regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Summary changed from Bad video can't be transcoded to avi regression
  • Version changed from unspecified to git-master

Regression since cbfdfbe8 / d3f610c1
Reproducible for example with:

$ ffmpeg -i 2015-09-14t12.47.26.avi -qscale 2 out.avi

comment:2 Changed 4 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.