Opened 4 years ago

Closed 3 years ago

#4828 closed enhancement (fixed)

use Core Audio AAC-encoder and AC3-decoder

Reported by: julian Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: audiotoolbox osx
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

it would be great if ffmpeg would be able to use the system provided Core Audio AAC-encoder and AC3-decoder under Mac OS X because Apple has payed the patent fees for these en/decoders for all uses. this would enable people to use ffmpeg to encode AAC & decode AC3 without patent concerns.

Change History (15)

comment:1 Changed 4 years ago by cehoyos

  • Keywords osx added
  • Version changed from unspecified to git-master

As-such, this ticket is clearly invalid: FFmpeg without the AAC and without the AC3 decoder most likely contains code covered by (many) software-patents. This is at least what several specifications and standards indicate.

Do these decoders have any other advantage over the decoders in FFmpeg? And how would they fit into the FFmpeg infrastructure? Would they just be two more external decoders?

Last edited 4 years ago by cehoyos (previous) (diff)

comment:2 follow-up: Changed 4 years ago by julian

As-such, this ticket is clearly invalid: FFmpeg without the AAC and without the AC3
decoder most likely contains code covered by (many) software-patents.

of course there are many other patented codecs inside ffmpeg. you configure ffmpeg to use them or not to use them. however, for the use case of just converting AC3 to AAC this would enable a patent-concern free solution (under OS X).

Do these decoders have any other advantage over the decoders in FFmpeg?

AFAIK blind listening tests have indicated the CoreAudio? AAC encoder to be top-notch

thats why the HandBrake? converter offers and prefers this over other AAC encoders.

adding this to libavformat would also allow HandBrake? to get rid of having to have code for both CoreAudio? AND libavformat audio encoding

for us, it would allow skipping using 'avconvert' Apple's native AAC encoding tool (which is patent worry free).

And how would they fit into the FFmpeg infrastructure? Would they just be two more external decoders?

i guess so

comment:3 Changed 4 years ago by kierank

Have you confirmed that the AC3 licence on Apple equipment permits non-Apple use?

comment:4 in reply to: ↑ 2 Changed 4 years ago by cehoyos

  • Status changed from new to open
  • Summary changed from use Core Audio AAC-encoder and AC3-decoder to avoid patent concerns to use Core Audio AAC-encoder and AC3-decoder

Replying to julian:

As-such, this ticket is clearly invalid: FFmpeg without the AAC and without the AC3
decoder most likely contains code covered by (many) software-patents.

of course there are many other patented codecs inside ffmpeg. you configure ffmpeg to use them or not to use them.

You misunderstand: I believe it is very unlikely that you succeed to configure FFmpeg so that it does not use patent-covered algorithms.

comment:5 follow-up: Changed 4 years ago by julian

Have you confirmed that the AC3 licence on Apple equipment permits non-Apple use?

Apple has definitely a AAC license for Core Audio that all developers can use, i'll post any resources on this
AC3 encoding has just been added to 'afconvert' to there hope this will soon be the same. Also AC3 expires in 2017 so its not as bad as AAC.

I believe it is very unlikely that you succeed to configure FFmpeg so that it does not use patent-covered algorithms.

can you elaborate. e.g. what patents would the process of just remuxing MKV to MP4 using ffmpeg without converting audio or video violate?

comment:6 in reply to: ↑ 5 Changed 4 years ago by cehoyos

Replying to julian:

I believe it is very unlikely that you succeed to configure FFmpeg so that it does not use patent-covered algorithms.

can you elaborate. e.g. what patents would the process of just remuxing MKV to MP4 using ffmpeg without converting audio or video violate?

FFmpeg's build system does not allow you to disable all possibly unused parts of FFmpeg.
(Is mov really patent-free?)

Note that this is completely irrelevant for this ticket: If somebody sends clean patches that allow to use the Apple codecs, I don't see a reason why they shouldn't be committed (if the commit message does not contain any hints to patents). I just want to make it completely clear that if there is a patent-issue, I find it very unlikely that you can fix it with these (hypothetical) patches.

comment:7 follow-up: Changed 4 years ago by heleppkes

Its also important to note that using Apple's encoders would most likely result in a non-free binary, so it would only be useful if you build it yourself, as any resulting binary couldn't be distributed anymore.

comment:8 in reply to: ↑ 7 Changed 4 years ago by cehoyos

Replying to heleppkes:

Its also important to note that using Apple's encoders would most likely result in a non-free binary, so it would only be useful if you build it yourself, as any resulting binary couldn't be distributed anymore.

How would it be different from using other system libraries?

comment:9 Changed 4 years ago by ponpon

+1 for this enhancement

i have found tool to access quick time by cli.
though i dont know if it is useful for ffmpeg, i attach its url.
qt_tools
http://www.omino.com/sw/qt_tools/

Last edited 4 years ago by ponpon (previous) (diff)

comment:11 in reply to: ↑ 10 Changed 4 years ago by ponpon

Replying to cehoyos:
gooooood!!
i am looking forward to it.

comment:12 Changed 3 years ago by klpu

How about on iOS

comment:13 Changed 3 years ago by klpu

How about on iOS

comment:14 in reply to: ↑ description Changed 3 years ago by klpu

Replying to julian:

it would be great if ffmpeg would be able to use the system provided Core Audio AAC-encoder and AC3-decoder under Mac OS X because Apple has payed the patent fees for these en/decoders for all uses. this would enable people to use ffmpeg to encode AAC & decode AC3 without patent concerns.

How about support iOS?

comment:15 Changed 3 years ago by cehoyos

  • Keywords audiotoolbox added
  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.