Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#4800 closed defect (invalid)

Does not recognize audio codec libfdk_aac when installed via apt-get

Reported by: michael.heuberger Owned by:
Priority: normal Component: undetermined
Version: 2.5.7 Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Initially reported at GitHub? and raised at other places, it seems that ffmpeg v2.5.8 doesn't seem to recognize the Fraunhofer audio code when it is separately installed via apt-get

Links:

Change History (10)

comment:1 Changed 4 years ago by llogan

  • Resolution set to invalid
  • Status changed from new to closed

You did not provide nearly enough information here, and all relevent information should be provided completely within the bug report instead of just providing links to unrelated, third-party sites.

Are you assuming that installing libfdk-aac-dev and/or libfdk-aac0 packages will enable this encoder in the ffmpeg from the repository? It doesn't work like that.

Or are you attempting to compile ffmpeg? If yes, then you need to at least show your configure line and the contents of config.log (or at least the first 50 and last 50 lines).

It is unclear as to what you are doing. I'm going to mark this as invalid until you provide enough information to allow us to reproduce any issue you may be experiencing.

comment:2 Changed 4 years ago by cehoyos

  • Component changed from ffmpeg to undetermined

And please test current FFmpeg git head before reporting an issue here.

comment:3 follow-ups: Changed 4 years ago by michael.heuberger

No, I am not compiling it here. Installed it via apt-get on Ubuntu 15.04. And the Frauenhofer libfdk_aac audio codec too, with apt-get.

Alright, the question then is how I can link both so that ffmpeg recognizes it?

comment:4 Changed 4 years ago by michael.heuberger

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:5 in reply to: ↑ 3 Changed 4 years ago by Timothy_Gu

Sorry about the duplicated comment. Removed.

Last edited 4 years ago by Timothy_Gu (previous) (diff)

comment:6 in reply to: ↑ 3 Changed 4 years ago by Timothy_Gu

  • Resolution set to invalid
  • Status changed from reopened to closed

Replying to michael.heuberger:

No, I am not compiling it here. Installed it via apt-get on Ubuntu 15.04. And the Frauenhofer libfdk_aac audio codec too, with apt-get.

Alright, the question then is how I can link both so that ffmpeg recognizes it?

As mentioned by llogan, it doesn't work like this. FFmpeg has to be recompiled to link to, and add support of, libfdk_aac.

comment:7 Changed 4 years ago by michael.heuberger

  • Resolution invalid deleted
  • Status changed from closed to reopened

Or can I tell the Ubuntu package maintainer to include it next time it gets compiled?

comment:8 Changed 4 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from reopened to closed

No.
Please understand that this is a bug tracker, you can get support on the user mailing list.

comment:9 Changed 4 years ago by llogan

Please understand that this is not a bug with FFmpeg (or fluent or Ubuntu). Due to its incompatible license (at least with GPL) libfdk is considered non-free which renders the binary non-free and unredistributable. This is why it is highly unlikely that Ubuntu will be able to provide a build supporting it.

If you need an ffmpeg build with support for this encoder then you must compile ffmpeg. See this encoding guide if you need help:
http://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu

If this is not acceptable then you'll have to either use a different encoder, or convince Fraunhofer to use a less shitty license, but it would probably be less painful to perform auto-appendectomy.

This ticket is considered closed. If you need additional help you should refer to the ffmpeg-user mailing list.

comment:10 Changed 4 years ago by michael.heuberger

good comment and i totally understand this now. i ll compile it by myself then.

many thanks

Note: See TracTickets for help on using tickets.