Opened 4 years ago

Closed 4 years ago

#4796 closed enhancement (wontfix)

Make vf_drawtext.c build under uclibc environments

Reported by: repzilon Owned by:
Priority: wish Component: avfilter
Version: 2.6.3 Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

The functions feclearexcept and fetestexcept, used in func_eval_expr_int_format, are not available under uclibc environments. For that platform, check if the number is finite and within bounds of a 32-bit signed integer before attempting the cast instead.

I made the patch against release 2.6.3 but applies cleanly against a git clone performed on August 22nd, 2015.

Attachments (1)

ffmpeg-2.6.3-uclibc.patch (923 bytes) - added by repzilon 4 years ago.

Download all attachments as: .zip

Change History (2)

Changed 4 years ago by repzilon

comment:1 Changed 4 years ago by cehoyos

  • Priority changed from normal to wish
  • Resolution set to wontfix
  • Status changed from new to closed

Please continue the discussion on the development mailing list, patches are ignored here.
http://thread.gmane.org/gmane.comp.video.ffmpeg.devel/197837

Closing since feature requests for old releases are invalid.

Note: See TracTickets for help on using tickets.