Opened 4 years ago

Closed 3 years ago

#4786 closed defect (fixed)

MLP misdetected for dvd_pcm

Reported by: patrakov Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: mpegps mlp
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

$ ffprobe ATS_01_1.AOB
ffprobe version 2.7.2 Copyright (c) 2007-2015 the FFmpeg developers
  built with gcc 5.2.0 (GCC)
  configuration: --prefix=/usr --disable-debug --disable-static --disable-stripping --enable-avisynth --enable-avresample --enable-fontconfig --enable-gnutls --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libv4l2 --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxvid --enable-shared --enable-version3 --enable-x11grab
  libavutil      54. 27.100 / 54. 27.100
  libavcodec     56. 41.100 / 56. 41.100
  libavformat    56. 36.100 / 56. 36.100
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 16.101 /  5. 16.101
  libavresample   2.  1.  0 /  2.  1.  0
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  2.100 /  1.  2.100
  libpostproc    53.  3.100 / 53.  3.100
Input #0, mpeg, from 'ATS_01_1.AOB':
  Duration: 00:00:22.96, start: 0.007333, bitrate: 3568 kb/s
    Stream #0:0[0xa1]: Audio: pcm_dvd, 48000 Hz, 6 channels, s16, 4608 kb/s

However the stream is actually MLP, not PCM, and is playable by VLC.

Attachments (2)

ATS_01_1.AOB (2.0 MB) - added by patrakov 4 years ago.
patchmpegmlp.diff (493 bytes) - added by cehoyos 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by patrakov

comment:1 Changed 4 years ago by patrakov

well, the output in the initial report was for a 10-megabyte sample, and the first 2 megabytes are attached because of the file size limit in this instance of Trac.

Changed 4 years ago by cehoyos

comment:2 Changed 4 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords mpegps mlp added
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

I just committed a patch that allows forcing mlp with the following command line:

$ ffmpeg -acodec mlp -i ATS_01_1.AOB​ out.wav

PoC attached that matches my original patches for issue 1731 on the mailing list:
http://thread.gmane.org/gmane.comp.video.ffmpeg.devel/142613
http://thread.gmane.org/gmane.comp.video.ffmpeg.devel/142629

comment:3 Changed 3 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed in fb9036b3142e06631a70810c3d779f8e2d9f180c - thank you for the sample!

Note: See TracTickets for help on using tickets.