Opened 4 years ago

Closed 4 years ago

#4682 closed defect (fixed)

ffmpeg 2.7 ignores forced FourCC (-vtag) while multiplexing to AVI

Reported by: LigH Owned by:
Priority: important Component: ffmpeg
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:

Multiplexing a raw MPEG4-ASP stream created by xvid_encraw (*.m4v) into an AVI container does not use the FourCC enforced with the parameter -vtag (instead keeps "FMP4").

How to reproduce:

ffmpeg -y -i "*.m4v" -vcodec copy -vtag XVID "*.avi"

More details in the attached report output.

Despite reporting to use the enforced FourCC "XVID", the AVI still contains the FourCC "FMP4" (for both locations in the AVI header).

Attachments (1)

ffmpeg-20150627-203803.log (4.5 KB) - added by LigH 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by LigH

comment:1 Changed 4 years ago by cehoyos

  • Component changed from ffmpeg to undetermined

Is this issue reproducible with current FFmpeg git head?

comment:2 Changed 4 years ago by LigH

Zathor reported it (in the doom9 forum) as not yet fixed in the latest zeranoe builds.

comment:3 Changed 4 years ago by cehoyos

  • Component changed from undetermined to ffmpeg
  • Keywords regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open

Regression since 95989463 / 3892bdab

comment:4 Changed 4 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.