Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#4411 closed defect (wontfix)

Unknown open() mode ':encoding(utf-8-strict)' at /usr/bin/texi2html

Reported by: thijs Owned by:
Priority: normal Component: documentation
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

When compiling the latest git head on OSX 10.7 the docs building fails with (for over a month now):

HOSTLD	doc/print_options
GENTEXI	doc/avoptions_format.texi
GENTEXI	doc/avoptions_codec.texi
HTML	doc/ffmpeg.html
Unknown open() mode ':encoding(utf-8-strict)' at /usr/bin/texi2html line 11111.
make: *** [doc/ffmpeg.html] Error 255

How to reproduce:

./configure --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-libcelt --enable-libfaac --enable-libfdk-aac --enable-libmp3lame --enable-openssl --enable-libspeex --enable-libtheora --enable-libvo-aacenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --prefix=/usr/local
make

Change History (5)

comment:1 Changed 4 years ago by Cigaes

The string utf-8-strict does not come from FFmpeg. It looks like an incompatibility with the versions of texi2html and perl you are using. Since both seem to come from the system, blame the system.

comment:2 Changed 4 years ago by thijs

Someone else also ran into this problem: https://hexeract.wordpress.com/2009/04/12/how-to-compile-ffmpegmplayer-for-macosx/#comment-2846

The suggested workaround is disabling the doc build, hmm. That report also suggests the error was introduced around ffmpeg 2.6 or 2.6.1.

comment:3 Changed 4 years ago by thijs

  • Resolution set to wontfix
  • Status changed from new to closed

I'll close this ticket, not much we can do I suppose, thanks for your feedback.

comment:4 follow-up: Changed 4 years ago by cehoyos

Installing texinfo 5.2 helped here on OSX 10.10 Yosemite.

I am still curious how to reproduce the issue: texi2html simply does not work here (and is not detected by configure) on Yosemite...

comment:5 in reply to: ↑ 4 Changed 4 years ago by thijs

Replying to cehoyos:

I am still curious how to reproduce the issue: texi2html simply does not work here (and is not detected by configure) on Yosemite...

$ texi2html --version
1.70
$ uname -a
Darwin Me.local 11.4.2 Darwin Kernel Version 11.4.2: Thu Aug 23 16:26:45 PDT 2012; root:xnu-1699.32.7~1/RELEASE_I386 i386
Note: See TracTickets for help on using tickets.