Opened 4 years ago

Closed 4 years ago

#4385 closed defect (invalid)

--disable-neon doesnt affect integration with libx265

Reported by: devizer Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: x265
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
Rasperry Pi's cpu doesnt support NEON. OS: Raspbian GNU/Linux 7 (wheezy)

ffmpeg's ./configure fails with error in log when --enable-libx265 is on:

/disk2/ffmpeg_build/lib/libx265.so: undefined reference to `x265_cpu_neon_test'
/disk2/ffmpeg_build/lib/libx265.so: undefined reference to `x265_cpu_fast_neon_mrc_test'
collect2: ld returned 1 exit status
ERROR: x265 not found using pkg-config

How have i built x265:

cd /disk2/ffmpeg_sources
hg --time clone https://bitbucket.org/multicoreware/x265
cd x265/build/linux
./make-Makefiles.bash
make
make install

Here is config of ffmpeg:

cd /disk2/ffmpeg_sources
wget http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
tar xjvf ffmpeg-snapshot.tar.bz2
cd ffmpeg
PATH="/disk2/fbin:$PATH" PKG_CONFIG_PATH="/disk2/ffmpeg_build/lib/pkgconfig" ./configure \
  --prefix="/disk2/ffmpeg_build" \
  --extra-cflags="-I/disk2/ffmpeg_build/include" \
  --extra-ldflags="-L/disk2/ffmpeg_build/lib" \
  --bindir="/disk2/fbin" \
  --enable-gpl \
  --enable-libass \
  --enable-libfdk-aac \
  --enable-libfreetype \
  --enable-libmp3lame \
  --enable-libopus \
  --enable-libtheora \
  --enable-libvorbis \
  --enable-libvpx \
  --enable-libx264 \
  --enable-libx265 \
  --enable-libv4l2 \
  --disable-neon --enable-vfp \
  --enable-nonfree

a configure, a make and an ffmpeg work fine without libx265 integration

Change History (2)

comment:1 Changed 4 years ago by heleppkes

This looks like a x265 problem, not a ffmpeg problem.

comment:2 Changed 4 years ago by jamrial

  • Keywords x265 added
  • Resolution set to invalid
  • Status changed from new to closed

This is a libx265 issue, so consider reporting it to them: https://bitbucket.org/multicoreware/x265/issues

Note: See TracTickets for help on using tickets.