Opened 3 years ago

Closed 2 years ago

#4281 closed defect (fixed)

-filter_complex causes SIGABRT

Reported by: Nyyr Owned by:
Priority: important Component: avfilter
Version: git-master Keywords: crash abort regression fade
Cc: michael Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:

I am trying to do a crossfade from one 25 frames MKV to another 25 frmaes MKV. ffmpeg crashes immediately...

How to reproduce:

/opt/ffmpeg/bin/ffmpeg -i 1_postak-e.mkv -i 2_postak-b.mkv -f lavfi -i "color=black" -filter_complex "[0:v]fade=t=out:d=1:alpha=1[v0];     [1:v]fade=t=in:d=1:alpha=1[v1];     [2:v]scale=pal,trim=duration=1[over];     [0:a]afade=out:d=1[a0];     [1:a]afade=in:d=1[a1];     [over][v0]overlay[over1];     [over1][v1]overlay[vout];     [a0][a1]amix=inputs=2[aout]" -map "[vout]" -map "[aout]" -target pal-dvd -q 1 -aspect 16:9 -f matroska -c:v huffyuv 1_postak-2_postak.mkv


ffmpeg version 2.5.git
downloaded and built on 2015-01-23

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Attachments (2)

ffmpeg.output (10.8 KB) - added by Nyyr 3 years ago.
Console output
ffmpeg-20150123-095133.log (15.0 KB) - added by Nyyr 3 years ago.
-report output

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by Nyyr

Console output

Changed 3 years ago by Nyyr

-report output

comment:1 Changed 3 years ago by michael

  • Cc michael added

Where can the input files be found or how can it be reproduced without them ?

comment:2 Changed 2 years ago by cehoyos

  • Component changed from undetermined to avfilter
  • Keywords crash abort regression fade added; filter_complex SIGABRT removed
  • Priority changed from normal to important
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed

http://thread.gmane.org/gmane.comp.video.ffmpeg.devel/189367
The issue was fixed in ab3ff19f and 2.6.
For the given command line, I believe this was a regression since a9f79728 - will be fixed in 2.5.7, 2.4.10 and 2.3.7.

Note: See TracTickets for help on using tickets.