Opened 3 years ago

Closed 3 years ago

#4250 closed defect (invalid)

Apostrophes are dropped from filenames passed via FFREPORT env variable

Reported by: hey_tommy Owned by:
Priority: normal Component: ffmpeg
Version: git-master Keywords: FFREPORT
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

When setting FFREPORT to a filename that contains an apostrophe (i.e. single quote), the apostrophe character is dropped from the report filename. Escaping with a single or a double caret, or doubling up the apostrophes does not lead to a positive outcome - any instances of the apostrophe character are simply ignored when parsed by ffmpeg.

(Since I'm using ffmpeg inside a script, and the existence of the report with a specific, dynamically parsed filename is used to determine whether a video file has been processed or not, it's important that I'm able to create reports using any characters that are valid in Windows file names.)

How to reproduce:

set FFREPORT=file=Breakfast.at.Tiffany's.1961.1080p.BluRay.DTS.x264-CRiSC.tmp

ffmpeg -i "Breakfast.at.Tiffany's.1961.1080p.BluRay.DTS.x264-CRiSC.mkv" -f null -

ffmpeg started on 2015-01-12 at 13:06:22
Report written to "Breakfast.at.Tiffanys.1961.1080p.BluRay.DTS.x264-CRiSC.tmp"
ffmpeg version N-68826-g504267f Copyright (c) 2000-2014 the FFmpeg developers
  built on Jan  2 2015 22:12:34 with gcc 4.9.2 (GCC)
.....

Platform: Windows 7 x64 SP1

Change History (1)

comment:1 Changed 3 years ago by Cigaes

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.