Opened 4 years ago

Closed 4 years ago

#4195 closed defect (invalid)

No bitrate reported for FLAC stream

Reported by: Đonny Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: FLAC
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
FFprobe does not report bitrate for a stream in a FLAC file, but it reports bitrate for the whole file.
I expect that if bitrate for whole file can be determined, and the file contains just one stream, the bitrate for that stream will be more or less same as stream of the file.
How to reproduce:

ffprobe sample.flac -print_format xml -show_streams -show_format
ffprobe version N-68500-g3ba1050 Copyright (c) 2007-2014 the FFmpeg developers
  built on Dec 17 2014 01:55:42 with gcc 4.9.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --e
nable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-li
bass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libfreetype --enable-li
bgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-lib
opencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-l
ibrtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --en
able-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable
-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-
libx265 --enable-libxavs --enable-libxvid --enable-decklink --enable-zlib
  libavutil      54. 15.100 / 54. 15.100
  libavcodec     56. 15.100 / 56. 15.100
  libavformat    56. 15.105 / 56. 15.105
  libavdevice    56.  3.100 / 56.  3.100
  libavfilter     5.  4.100 /  5.  4.100
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  3.100 / 53.  3.100
<?xml version="1.0" encoding="UTF-8"?>
<ffprobe>
Input #0, flac, from 'sample.flac':
  Duration: 00:00:04.40, start: 0.000000, bitrate: 111 kb/s
    Stream #0:0: Audio: flac, 8000 Hz, mono, s16
    <streams>
        <stream index="0" codec_name="flac" codec_long_name="FLAC (Free Lossless Audio Cod
ec)" codec_type="audio" codec_time_base="1/8000" codec_tag_string="[0][0][0][0]" codec_tag
="0x0000" sample_fmt="s16" sample_rate="8000" channels="1" channel_layout="mono" bits_per_
sample="0" r_frame_rate="0/0" avg_frame_rate="0/0" time_base="1/8000" start_pts="0" start_
time="0.000000" duration_ts="35195" duration="4.399375" bits_per_raw_sample="16">
            <disposition default="0" dub="0" original="0" comment="0" lyrics="0" karaoke="
0" forced="0" hearing_impaired="0" visual_impaired="0" clean_effects="0" attached_pic="0"/
>
        </stream>
    </streams>

    <format filename="sample.flac" nb_streams="1" nb_programs="0" format_name="flac" forma
t_long_name="raw FLAC" start_time="0.000000" duration="4.399375" size="61522" bit_rate="11
1874" probe_score="50"/>
</ffprobe>

Attachments (1)

sample.flac (60.1 KB) - added by Đonny 4 years ago.
The input file for which FFprobe does not report bitrate of stream

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by Đonny

The input file for which FFprobe does not report bitrate of stream

comment:1 Changed 4 years ago by cehoyos

  • Keywords FFprobe removed

I wonder if this isn't the intended behaviour given that a flac stream never has a bitrate in the usual sense but every media stream has a (meaningless) average bitrate.

For future tickets: Please only provide ffprobe output for issues that are not reproducible with ffmpeg.

comment:2 Changed 4 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

To the best of my knowledge, this works as intended.

Note: See TracTickets for help on using tickets.