Opened 5 years ago

Closed 5 years ago

#4065 closed defect (duplicate)

support aspect-ratio changes in scale and pad filters

Reported by: mikaraento Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Currently it's reasonably easy to column (and letter) -box fixed-aspect-ratio input in ffmpeg, by using something like:

ffmpeg -filter_complex '[0:0]scale=iw*sar:ih,scale=-1:432,pad=768:432:(ow-iw)/2:(oh-ih)/2,setdar=16:9[outv]'

However, if the input has aspect-ratio changes (dimensions or sar) mid-stream, the above won't work.

It would be nice to have per-frame -evaluated versions of the variables for scale and pad. (and the required other changes in these filters that assume that they don't change)

Change History (1)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from avfilter to undetermined
  • Resolution set to duplicate
  • Status changed from new to closed
  • Type changed from enhancement to defect

This sounds like a duplicate of ticket #3631 to me.

Note: See TracTickets for help on using tickets.