Opened 3 years ago

Closed 3 months ago

#4026 closed defect (needs_more_info)

AAC Number of bands exceeds limit

Reported by: sssr33 Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: aac rtsp
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
Latest (git-20df026 (2014-10-12)) ffplay from zeranoe fails to play audio stream while VLC player can.
How to reproduce:
You can reproduce this with this links:
rtsp://46.249.213.87:554/playlists/france-24_hvga.hpl.3gp
rtsp://46.249.213.87:554/playlists/ftv_hvga.hpl.3gp

C:\Users\Alexander>ffplay rtsp://46.249.213.87:554/playlists/ftv_hvga.hpl.3gp
ffplay version N-66809-g20df026 Copyright (c) 2003-2014 the FFmpeg developers
  built on Oct 11 2014 23:32:18 with gcc 4.9.1 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --
enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-lib
modplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrw
b --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinge
r --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --en
able-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis
 --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-
libx265 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil      54. 10.100 / 54. 10.100
  libavcodec     56.  4.101 / 56.  4.101
  libavformat    56.  9.100 / 56.  9.100
  libavdevice    56.  1.100 / 56.  1.100
  libavfilter     5.  1.103 /  5.  1.103
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  1.100 / 53.  1.100
[rtsp @ 027f7c80] method SETUP failed: 461 Unsupported transport0
[h264 @ 027fad00] illegal short term buffer state detectedB f=0/0
    Last message repeated 1 times
[rtsp @ 027f7c80] Could not find codec parameters for stream 1 (Video: none, 450
 kb/s): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[rtsp @ 027f7c80] Could not find codec parameters for stream 2 (Video: none, 600
 kb/s): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, rtsp, from 'rtsp://46.249.213.87:554/playlists/ftv_hvga.hpl.3gp':
  Metadata:
    title           : Fashion TV
    comment         : <No author> (c) 2010
  Duration: N/A, start: 0.000000, bitrate: 1448 kb/s
    Stream #0:0: Video: h264 (Baseline), yuv420p, 480x272, 350 kb/s, 30 tbr, 90k
 tbn, 180k tbc
    Stream #0:1: Video: none, 450 kb/s, 90k tbr, 90k tbn, 90k tbc
    Stream #0:2: Video: none, 600 kb/s, 90k tbr, 90k tbn, 90k tbc
    Stream #0:3: Audio: aac, 32000 Hz, stereo, fltp, 48 kb/s
[aac @ 027fc9c0] Invalid bitstream, too many QMF subbands: 38
[aac @ 027fc9c0] SBR reset failed. Switching SBR to pure upsampling mode.
[h264 @ 050597c0] illegal short term buffer state detected
[h264 @ 05059bc0] illegal short term buffer state detected
[h264 @ 0505aba0] illegal short term buffer state detectedB f=0/0
[aac @ 027fc9c0] Number of scalefactor bands in group (15) exceeds limit (14).
[aac @ 027fc9c0] Number of bands (43) exceeds limit (42).
[aac @ 027fc9c0] invalid band type
[h264 @ 028b78a0] illegal short term buffer state detected
[aac @ 027fc9c0] Number of bands (51) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (55) exceeds limit (42).
[aac @ 027fc9c0] invalid band type
[aac @ 027fc9c0] Number of bands (57) exceeds limit (42).0B f=0/0
[aac @ 027fc9c0] Number of bands (44) exceeds limit (42).
[aac @ 027fc9c0] invalid band type
[aac @ 027fc9c0] Number of bands (48) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (50) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (53) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (47) exceeds limit (42).
[aac @ 027fc9c0] invalid band type
[aac @ 027fc9c0] Number of bands (43) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (68) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (57) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (49) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (51) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (45) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (48) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (47) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (51) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (43) exceeds limit (42).
[aac @ 027fc9c0] Number of bands (49) exceeds limit (42).

Change History (7)

comment:1 follow-up: Changed 3 years ago by cehoyos

The stream unfortunately does not play with vlc here either.
Could you test with vlc --codec=ffmpeg to narrow the issue down?

comment:2 in reply to: ↑ 1 Changed 3 years ago by sssr33

Replying to cehoyos:

The stream unfortunately does not play with vlc here either.
Could you test with vlc --codec=ffmpeg to narrow the issue down?

I have tested it on Windows 8.1, desktop VLC 2.1.3 and it have sound.
Here is info for 1st stream:
http://my.jetscreenshot.com/demo/20141016-ewe4-45kb
http://my.jetscreenshot.com/demo/20141016-d3gh-48kb
As you can see on 2nd screenshot VLC is decoding and playing audio.

And if I run "C:\Program Files (x86)\VideoLAN\VLC\vlc.exe" --codec=ffmpeg rtsp://46.249.213.87:554/playlists/france-24_hvga.hpl.3gp in cmd it is also have sound.

comment:3 Changed 3 years ago by cehoyos

  • Component changed from avcodec to avformat
  • Keywords rtsp added
  • Status changed from new to open

This indicates imo that the problem is not in libavcodec.

comment:4 Changed 20 months ago by richardpl

Is there sample for this?

comment:5 Changed 13 months ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from open to closed

Sadly, the stream is now 404.

comment:6 Changed 4 months ago by cturner

  • Keywords rtsp removed
  • Resolution needs_more_info deleted
  • Status changed from closed to reopened

I found a new stream that gives me errors similar to the above (I found this ticket from Google, let me know if you'd like a new one instead).

The video file inlined on this blog post exhibits the problems: http://wingolog.org/archives/2017/06/29/a-new-concurrent-ml

I built ffmpeg at 95f3c85976ff79af6fd10ce3f7a90fcb054c3fc0

ffplay version N-86703-g95f3c85 Copyright (c) 2003-2017 the FFmpeg developers
  built with gcc 6.3.1 (GCC) 20161221 (Red Hat 6.3.1-1)
  configuration: 
  libavutil      55. 67.100 / 55. 67.100
  libavcodec     57.100.103 / 57.100.103
  libavformat    57. 75.100 / 57. 75.100
  libavdevice    57.  7.100 / 57.  7.100
  libavfilter     6. 94.100 /  6. 94.100
  libswscale      4.  7.101 /  4.  7.101
  libswresample   2.  8.100 /  2.  8.100

And if I play the file there, I see,

[aac @ 0x7f2914007a80] channel element 3.14 is not allocated
[aac @ 0x7f2914007a80] Sample rate index in program config element does not match the sample rate index configured by the container.
[aac @ 0x7f2914007a80] Too large remapped id is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been imple
mented.
[aac @ 0x7f2914007a80] If you want to help, upload a sample of this file to ftp://upload.ffmpeg.org/incoming/ and contact the ffmpeg-devel mailing list. (ffmpeg-devel@ffmpeg.org)
[aac @ 0x7f2914007a80] SBR was found before the first channel element.
[aac @ 0x7f2914007a80] channel element 2.4 is not allocated
[aac @ 0x7f2914007a80] Number of bands (7) exceeds limit (5).
[aac @ 0x7f2914007a80] channel element 3.13 is not allocated
[aac @ 0x7f2914007a80] invalid band type
[aac @ 0x7f2914007a80] Sample rate index in program config element does not match the sample rate index configured by the container.
[aac @ 0x7f2914007a80] Inconsistent channel configuration.
[aac @ 0x7f2914007a80] get_buffer() failed
[aac @ 0x7f2914007a80] Number of scalefactor bands in group (52) exceeds limit (49).
[aac @ 0x7f2914007a80] Number of bands (52) exceeds limit (39).
[aac @ 0x7f2914007a80] channel element 3.14 is not allocated
[aac @ 0x7f2914007a80] channel element 3.4 is not allocated
[aac @ 0x7f2914007a80] Reserved bit set.
[aac @ 0x7f2914007a80] SSR is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
[aac @ 0x7f2914007a80] If you want to help, upload a sample of this file to ftp://upload.ffmpeg.org/incoming/ and contact the ffmpeg-devel mailing list. (ffmpeg-devel@ffmpeg.org)
[aac @ 0x7f2914007a80] Inconsistent channel configuration.
[aac @ 0x7f2914007a80] get_buffer() failed
[aac @ 0x7f2914007a80] Multiple frames in a packet.
[aac @ 0x7f2914007a80] channel element 2.6 is not allocated
[aac @ 0x7f2914007a80] channel element 3.9 is not allocated
[aac @ 0x7f2914007a80] SBR was found before the first channel element.
[aac @ 0x7f2914007a80] channel element 3.6 is not allocated
[aac @ 0x7f2914007a80] Reserved bit set.
[aac @ 0x7f2914007a80] Prediction is not allowed in AAC-LC.
[aac @ 0x7f2914007a80] channel element 2.10 is not allocated
[aac @ 0x7f2914007a80] More than one AAC RDB per ADTS frame is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
[aac @ 0x7f2914007a80] channel element 2.1 is not allocated
[aac @ 0x7f2914007a80] Sample rate index in program config element does not match the sample rate index configured by the container.
[aac @ 0x7f2914007a80] Too large remapped id is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
[aac @ 0x7f2914007a80] If you want to help, upload a sample of this file to ftp://upload.ffmpeg.org/incoming/ and contact the ffmpeg-devel mailing list. (ffmpeg-devel@ffmpeg.org)
...

Let me know if I can provide further info.

comment:7 Changed 3 months ago by cehoyos

  • Keywords rtsp added
  • Resolution set to needs_more_info
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.