Opened 5 years ago

Closed 4 years ago

#4012 closed defect (fixed)

Transcoding Slo-Mo MOVs from iPhone results in awful MP4

Reported by: hendry Owned by:
Priority: important Component: undetermined
Version: git-master Keywords: mov regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug: I simply want to share on the Web, videos from my iPhone taken with the Slo-Mo feature

How to reproduce:
Transcode my MOVs to MP4s like a usually do with https://github.com/kaihendry/recordmydesktop2.0/ and the resulting MP4's audio is mal-aligned and the video playback is unwatchable (full of pauses). I've tested playback on Chrome 39.0.2171.7, Firefox 32 and IOS safari. All basically unusable result from ffmpeg.

% ffmpeg -y -i "$input" -movflags +faststart -pix_fmt yuv420p -c:v libx264 -vprofile baseline -acodec aac -strict experimental "$out"
version 2.4.2
built on Archlinux

Warning about high frame rate:
http://s.natalian.org/2014-10-07/1412660525_1364x742.png

Original "Slo-Mo": http://s.natalian.org/2014-10-07/IMG_4596.MOV
Transcoded result: http://s.natalian.org/2014-10-05/IMG_4596.mp4

Change History (6)

comment:1 Changed 5 years ago by cehoyos

  • Keywords mov added; ios removed

Please test current FFmpeg git head and please provide the command line you tested together with the complete, uncut console output to make this a valid ticket.
Please use default verbosity (or higher).

comment:2 Changed 5 years ago by hendry

I don't have the time to checkout and build latest ffmpeg and ramp up the verbosity for paste it in here for you. It's a valid ticket.

comment:3 Changed 5 years ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important
  • Version changed from 2.4.2 to git-master

comment:4 Changed 5 years ago by michael

"Keywords regression added", regression since which commit ?

comment:5 Changed 5 years ago by cehoyos

I am still hoping that somebody fills in the missing information (I don't have enough time atm), that's why I left the status at "new". In case somebody wants to work on an important ticket, I mentioned that this is a regression.

comment:6 Changed 4 years ago by michael

  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.