Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3944 closed enhancement (fixed)

Documentation for the libx265 wrapper is missing

Reported by: raine Owned by:
Priority: minor Component: documentation
Version: git-master Keywords: libx265
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description (last modified by Timothy_Gu)

libx265 has options: preset, tune, and x265-param. They are not documented in doc/encoders.texi.

This ticket was originally about missing option to adjust --psy-rd x265 option. That is invalid because there is an undocumented way to adjust it. This ticket now acts as a reminder to add more documentation for x265. See 2.


Original bug description:
x265 supports psycho-visual options since v1.2 (--psy-rd, --psy-rdoq, also related is --rd):
http://x265.readthedocs.org/en/default/cli.html#pycho-visual-options

ffmpeg should provide a way of passing these options to libx265.

I'm guessing there are many other missing options too.

Change History (5)

comment:1 Changed 5 years ago by jamal

  • Resolution set to invalid
  • Status changed from new to closed

All parameters are passed with the -x265-params AVOption, which takes a : separated list of key=value parameters.
For instance:

ffmpeg -i INPUT -c:v libx265 -x265-params psy-rd=1 OUTPUT

comment:2 Changed 5 years ago by jamal

  • Component changed from ffmpeg to documentation
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Summary changed from Allow passing psycho-visual options via x265-params to Documentation for the libx265 wrapper is missing
  • Type changed from defect to enhancement
  • Version changed from 2.3.3 to git-master

On second thought, i'll keep the ticket open since this is a documentation issue (Namely, there isn't any).

comment:3 Changed 5 years ago by Timothy_Gu

  • Description modified (diff)
  • Priority changed from normal to minor

comment:4 Changed 5 years ago by llogan

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:5 Changed 5 years ago by cehoyos

  • Keywords libx265 added; x265 removed
Note: See TracTickets for help on using tickets.