Opened 5 years ago

Closed 5 years ago

#3912 closed defect (fixed)

asf: file doesn't decode correctly anymore

Reported by: ami_stuff Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: asp
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

IMAG0002.ASF decoded correctly with git-gd0f56ca Aug 3 2014.

http://samples.mplayerhq.hu/asf-wmv/IMAG0002.ASF

C:\>ffmpeg -i IMAG0002.ASF out.avi
ffmpeg version N-66012-g97b8809 Copyright (c) 2000-2014 the FFmpeg developers
  built on Sep  1 2014 00:07:41 with gcc 4.8.3 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --
enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-lib
modplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrw
b --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinge
r --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --en
able-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis
 --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-
libx265 --enable-libxavs --enable-libxvid --enable-decklink --enable-zlib
  libavutil      54.  7.100 / 54.  7.100
  libavcodec     56.  1.100 / 56.  1.100
  libavformat    56.  3.100 / 56.  3.100
  libavdevice    56.  0.100 / 56.  0.100
  libavfilter     5.  0.103 /  5.  0.103
  libswscale      3.  0.100 /  3.  0.100
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  0.100 / 53.  0.100
[asf @ 02e1c020] ff asf bad header 11  at:16387
[asf @ 02e1c020] ff asf bad header 11  at:32771
[mpeg4 @ 02e1aca0] Failed to parse extradata
[asf @ 02e1c020] ff asf bad header 11  at:49155
[asf @ 02e1c020] ff asf bad header 11  at:65539
[asf @ 02e1c020] ff asf bad header 11  at:81923
[asf @ 02e1c020] ff asf bad header 11  at:98307
[asf @ 02e1c020] ff asf bad header 11  at:114691
[asf @ 02e1c020] ff asf bad header 11  at:131075
[asf @ 02e1c020] ff asf bad header 11  at:147459
[asf @ 02e1c020] ff asf bad header 11  at:163843
[asf @ 02e1c020] ff asf bad header 11  at:180227
[asf @ 02e1c020] ff asf bad header 11  at:196611
[asf @ 02e1c020] ff asf bad header 11  at:212995
Guessed Channel Layout for  Input Stream #0.0 : mono
Input #0, asf, from 'IMAG0002.ASF':
  Duration: 00:00:05.53, start: 0.042000, bitrate: 949 kb/s
    Stream #0:0: Audio: adpcm_ima_wav ([17][0][0][0] / 0x0011), 24000 Hz, 1 chan
nels, s16p, 96 kb/s
    Stream #0:1: Video: mpeg4 (MP4S / 0x5334504D), yuv420p, 352x288 [SAR 1:1 DAR
 11:9], 30 fps, 30 tbr, 1k tbn, 30k tbc
Output #0, avi, to 'out.avi':
  Metadata:
    ISFT            : Lavf56.3.100
    Stream #0:0: Video: mpeg4 (FMP4 / 0x34504D46), yuv420p, 352x288 [SAR 1:1 DAR
 11:9], q=2-31, 200 kb/s, 30 fps, 30 tbn, 30 tbc
    Metadata:
      encoder         : Lavc56.1.100 mpeg4
    Stream #0:1: Audio: mp3 (libmp3lame) (U[0][0][0] / 0x0055), 24000 Hz, mono,
s16p
    Metadata:
      encoder         : Lavc56.1.100 libmp3lame
Stream mapping:
  Stream #0:1 -> #0:0 (mpeg4 (native) -> mpeg4 (native))
  Stream #0:0 -> #0:1 (adpcm_ima_wav (native) -> mp3 (libmp3lame))
Press [q] to stop, [?] for help
[mpeg4 @ 02fee940] Error at MB: 168
[mpeg4 @ 02fee940] concealing 189 DC, 189 AC, 189 MV errors in I frame
[mpeg4 @ 02feede0] Error at MB: 145
[mpeg4 @ 02feede0] concealing 217 DC, 217 AC, 217 MV errors in P frame
Input stream #0:1 frame changed from size:352x288 fmt:yuv420p to size:320x240 fm
t:yuv420p
[mpeg4 @ 06717c20] Error at MB: 168
[mpeg4 @ 067223e0] Error at MB: 37
[mpeg4 @ 06717c20] concealing 194 DC, 194 AC, 194 MV errors in P frame
[mpeg4 @ 067223e0] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 0671dca0] Error at MB: 124
[mpeg4 @ 0671ba40] Error at MB: 165
[mpeg4 @ 0671dca0] concealing 230 DC, 230 AC, 230 MV errors in P frame
[mpeg4 @ 0671ba40] concealing 195 DC, 195 AC, 195 MV errors in P frame
[mpeg4 @ 06720040] Error at MB: 101
[mpeg4 @ 06720040] concealing 252 DC, 252 AC, 252 MV errors in P frame
[mpeg4 @ 06717c20] Error at MB: 80
[mpeg4 @ 06717c20] concealing 272 DC, 272 AC, 272 MV errors in P frame
[mpeg4 @ 06719b80] Error at MB: 128
[mpeg4 @ 0671ba40] Error at MB: 33
[mpeg4 @ 06719b80] concealing 227 DC, 227 AC, 227 MV errors in P frame
[mpeg4 @ 0671ba40] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 067223e0] Error at MB: 38
[mpeg4 @ 067223e0] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 06724780] Error at MB: 56
[mpeg4 @ 06724780] concealing 295 DC, 295 AC, 295 MV errors in P frame
[mpeg4 @ 02fee940] Error at MB: 80
[mpeg4 @ 02fee940] concealing 272 DC, 272 AC, 272 MV errors in P frame
[mpeg4 @ 02fee940] Error at MB: 30
[mpeg4 @ 02fee940] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 06719b80] Error at MB: 140
[mpeg4 @ 06719b80] concealing 215 DC, 215 AC, 215 MV errors in I frame
[mpeg4 @ 0671dca0] Error at MB: 116
[mpeg4 @ 0671dca0] concealing 238 DC, 238 AC, 238 MV errors in P frame
[mpeg4 @ 06720040] Error at MB: 37
[mpeg4 @ 06720040] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 02fee940] Error at MB: 33
[mpeg4 @ 02fee940] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 06719b80] Error at MB: 78
[mpeg4 @ 06719b80] concealing 274 DC, 274 AC, 274 MV errors in P frame
[mpeg4 @ 06720040] Error at MB: 33
[asf @ 02e1c020] ff asf bad header 11  at:229379
[mpeg4 @ 06720040] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 06724780] Error at MB: 76
[mpeg4 @ 06724780] concealing 276 DC, 276 AC, 276 MV errors in P frame
[mpeg4 @ 0671ba40] Error at MB: 22
[asf @ 02e1c020] ff asf bad header 11  at:245763
[mpeg4 @ 0671ba40] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 0671dca0] Error at MB: 21
[mpeg4 @ 0671dca0] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 06720040] Error at MB: 46
[asf @ 02e1c020] ff asf bad header 11  at:262147
[mpeg4 @ 06720040] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 067223e0] Error at MB: 27
[mpeg4 @ 067223e0] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 06720040] Error at MB: 93
[mpeg4 @ 02fee940] Error at MB: 69
[mpeg4 @ 02feede0] Error at MB: 22
[mpeg4 @ 06720040] concealing 260 DC, 260 AC, 260 MV errors in I frame
[asf @ 02e1c020] ff asf bad header 11  at:278531
[mpeg4 @ 02fee940] concealing 283 DC, 283 AC, 283 MV errors in P frame
[mpeg4 @ 02feede0] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 06719b80] Error at MB: 52
[mpeg4 @ 06719b80] concealing 299 DC, 299 AC, 299 MV errors in P frame
[mpeg4 @ 0671ba40] Error at MB: 27
[asf @ 02e1c020] ff asf bad header 11  at:294915
[mpeg4 @ 0671ba40] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 06724780] Error at MB: 53
[mpeg4 @ 06724780] concealing 298 DC, 298 AC, 298 MV errors in P frame
[mpeg4 @ 06719b80] Error at MB: 31
[mpeg4 @ 06717c20] Error at MB: 233
[asf @ 02e1c020] ff asf bad header 11  at:311299
[mpeg4 @ 06719b80] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 06717c20] concealing 127 DC, 127 AC, 127 MV errors in P frame
[mpeg4 @ 06720040] Error at MB: 28
[mpeg4 @ 06720040] concealing 300 DC, 300 AC, 300 MV errors in P frame
[asf @ 02e1c020] ff asf bad header 11  at:327683
[mpeg4 @ 02fee940] Error at MB: 55
[mpeg4 @ 02fee940] concealing 296 DC, 296 AC, 296 MV errors in P frame
[mpeg4 @ 06719b80] Error at MB: 152
[asf @ 02e1c020] ff asf bad header 11  at:344067
[mpeg4 @ 06719b80] concealing 204 DC, 204 AC, 204 MV errors in P frame
[mpeg4 @ 06720040] Error at MB: 79
[mpeg4 @ 06720040] concealing 273 DC, 273 AC, 273 MV errors in P frame
[mpeg4 @ 0671ba40] Error at MB: 193
[mpeg4 @ 0671dca0] Error at MB: 152
[mpeg4 @ 06724780] Error at MB: 97
[mpeg4 @ 067223e0] Error at MB: 231
[asf @ 02e1c020] ff asf bad header 11  at:360451
[mpeg4 @ 0671ba40] concealing 165 DC, 165 AC, 165 MV errors in P frame
[mpeg4 @ 0671dca0] concealing 204 DC, 204 AC, 204 MV errors in P frame
[mpeg4 @ 06724780] concealing 256 DC, 256 AC, 256 MV errors in P frame
[mpeg4 @ 067223e0] concealing 129 DC, 129 AC, 129 MV errors in P frame
[mpeg4 @ 02fee940] Error at MB: 69
[asf @ 02e1c020] ff asf bad header 11  at:376835
[mpeg4 @ 02fee940] concealing 283 DC, 283 AC, 283 MV errors in P frame
[mpeg4 @ 02feede0] Error at MB: 143
[mpeg4 @ 06717c20] Error at MB: 101
[asf @ 02e1c020] ff asf bad header 11  at:393219
[mpeg4 @ 02feede0] concealing 214 DC, 214 AC, 214 MV errors in P frame
[mpeg4 @ 06717c20] concealing 252 DC, 252 AC, 252 MV errors in P frame
[asf @ 02e1c020] ff asf bad header 11  at:409603
[mpeg4 @ 0671ba40] Error at MB: 210
[mpeg4 @ 02fee940] Error at MB: 69
[mpeg4 @ 0671ba40] concealing 151 DC, 151 AC, 151 MV errors in P frame
[mpeg4 @ 02fee940] concealing 283 DC, 283 AC, 283 MV errors in I frame
[asf @ 02e1c020] ff asf bad header 11  at:425987
[mpeg4 @ 067223e0] Error at MB: 292
[mpeg4 @ 0671ba40] Error at MB: 169
[mpeg4 @ 067223e0] concealing 70 DC, 70 AC, 70 MV errors in P frame
[mpeg4 @ 0671ba40] concealing 188 DC, 188 AC, 188 MV errors in P frame
[asf @ 02e1c020] ff asf bad header 11  at:442371
[mpeg4 @ 06724780] Error at MB: 304
[mpeg4 @ 06720040] Error at MB: 242
[mpeg4 @ 06724780] concealing 59 DC, 59 AC, 59 MV errors in P frame
[mpeg4 @ 067223e0] Error at MB: 185
[mpeg4 @ 06720040] concealing 118 DC, 118 AC, 118 MV errors in P frame
[mpeg4 @ 067223e0] concealing 173 DC, 173 AC, 173 MV errors in P frame
[asf @ 02e1c020] ff asf bad header 11  at:458755
[mpeg4 @ 02feede0] Error at MB: 109
[asf @ 02e1c020] ff asf bad header 11  at:475139
[mpeg4 @ 02feede0] concealing 245 DC, 245 AC, 245 MV errors in P frame
[mpeg4 @ 06719b80] Error at MB: 64
[mpeg4 @ 06717c20] Error at MB: 152
[mpeg4 @ 06719b80] concealing 288 DC, 288 AC, 288 MV errors in P frame
[mpeg4 @ 06717c20] concealing 205 DC, 205 AC, 205 MV errors in P frame
[asf @ 02e1c020] ff asf bad header 11  at:491523
[mpeg4 @ 06720040] Error at MB: 34
[mpeg4 @ 0671dca0] Error at MB: 124
[mpeg4 @ 06720040] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 0671dca0] concealing 231 DC, 231 AC, 231 MV errors in P frame
[asf @ 02e1c020] ff asf bad header 11  at:507907
[mpeg4 @ 02fee940] Error at MB: 35
[mpeg4 @ 02fee940] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 06719b80] Error at MB: 34
[mpeg4 @ 06719b80] concealing 300 DC, 300 AC, 300 MV errors in P frame
[asf @ 02e1c020] ff asf bad header 11  at:524291
[mpeg4 @ 067223e0] Error at MB: 37
[mpeg4 @ 067223e0] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 06724780] Error at MB: 58
[mpeg4 @ 06724780] concealing 293 DC, 293 AC, 293 MV errors in P frame
[asf @ 02e1c020] ff asf bad header 11  at:540675
[mpeg4 @ 02fee940] Error at MB: 80
[mpeg4 @ 02fee940] concealing 272 DC, 272 AC, 272 MV errors in P frame
[mpeg4 @ 06719b80] Error at MB: 29
[asf @ 02e1c020] ff asf bad header 11  at:557059
[mpeg4 @ 06719b80] concealing 300 DC, 300 AC, 300 MV errors in I frame
[mpeg4 @ 0671dca0] Error at MB: 38
[mpeg4 @ 0671ba40] Error at MB: 108
[mpeg4 @ 0671dca0] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 0671ba40] concealing 246 DC, 246 AC, 246 MV errors in P frame
[asf @ 02e1c020] ff asf bad header 11  at:573443
[mpeg4 @ 06720040] Error at MB: 53
[mpeg4 @ 06720040] concealing 298 DC, 298 AC, 298 MV errors in P frame
[mpeg4 @ 067223e0] Error at MB: 85
[mpeg4 @ 067223e0] concealing 268 DC, 268 AC, 268 MV errors in P frame
[asf @ 02e1c020] ff asf bad header 11  at:589827
[mpeg4 @ 02feede0] Error at MB: 46
[mpeg4 @ 02fee940] Error at MB: 158
[mpeg4 @ 02feede0] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 02fee940] concealing 198 DC, 198 AC, 198 MV errors in P frame
[asf @ 02e1c020] ff asf bad header 11  at:606211
[mpeg4 @ 06717c20] Error at MB: 69
[mpeg4 @ 06717c20] concealing 283 DC, 283 AC, 283 MV errors in P frame
[asf @ 02e1c020] ff asf bad header 11  at:622595
[mpeg4 @ 0671ba40] Error at MB: 67
[asf @ 02e1c020] ff asf bad header 11  at:638979
[mpeg4 @ 0671ba40] concealing 285 DC, 285 AC, 285 MV errors in P frame
[mpeg4 @ 0671dca0] Error at MB: 23
[mpeg4 @ 0671dca0] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 06720040] Error at MB: 46
[mpeg4 @ 06720040] concealing 300 DC, 300 AC, 300 MV errors in P frame
[mpeg4 @ 067223e0] Error at MB: 22
[mpeg4 @ 067223e0] concealing 300 DC, 300 AC, 300 MV errors in P frame
frame=  143 fps=0.0 q=31.0 Lsize=     336kB time=00:00:04.92 bitrate= 558.9kbits
/s
video:298kB audio:19kB subtitle:0kB other streams:0kB global headers:0kB muxing
overhead: 5.726791%

Change History (2)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords asp added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Regression since 595c6335 / b869eea7

comment:2 Changed 5 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.