Opened 4 years ago

Closed 4 years ago

#3717 closed defect (fixed)

vp9 artifacts

Reported by: kyh96403 Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: vp9 regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Change History (5)

comment:1 Changed 4 years ago by ubitux

  • Reproduced by developer set
  • Status changed from new to open

Green artifact visible with:

% ./ffplay -ss 24 -i /tmp/la\ la\ la.webm
ffplay version N-63900-g0180c46 Copyright (c) 2003-2014 the FFmpeg developers
  built on Jun 11 2014 21:33:53 with gcc 4.9.0 (GCC) 20140521 (prerelease)
  configuration: --enable-gpl --enable-fontconfig --enable-libfreetype --enable-libmp3lame --enable-libvorbis --enable-libx264 --enable-libvpx --enable-x11grab --samples=/home/ubitux/fate-samples --assert-level=2 --cc='ccache cc'
  libavutil      52. 89.100 / 52. 89.100
  libavcodec     55. 66.100 / 55. 66.100
  libavformat    55. 43.100 / 55. 43.100
  libavdevice    55. 13.101 / 55. 13.101
  libavfilter     4.  8.100 /  4.  8.100
  libswscale      2.  6.100 /  2.  6.100
  libswresample   0. 19.100 /  0. 19.100
  libpostproc    52.  3.100 / 52.  3.100
Input #0, matroska,webm, from '/tmp/la la la.webm':q=    0B f=0/0   
  Metadata:
    encoder         : google
  Duration: 00:03:30.28, start: 0.000000, bitrate: 1868 kb/s
    Stream #0:0(eng): Video: vp9, yuv420p, 1920x1080, SAR 1:1 DAR 16:9, 25 fps, 25 tbr, 1k tbn, 1k tbc (default)
  23.80 M-V:  0.000 fd=   0 aq=    0KB vq=   42KB sq=    0B f=0/0   

Problem seems to be in ASM (not reproducible with -cpuflags none), in particular init_dc_ipred(TX_4X4, 4, ssse3);.

It would be really nice if you could upload the sample on our FTP. Mentioning our bugreport page (http://ffmpeg.org/bugreports.html):

Furthermore movie files uploaded to services like megaupload, rapidshare or any other similar service will be ignored. We are not willing to spend our time fighting with this ridiculous, bloated and spam-filled crap.

comment:2 Changed 4 years ago by cehoyos

  • Keywords regression added; artifacts removed
  • Priority changed from normal to important

comment:3 follow-up: Changed 4 years ago by cehoyos

Regression since fdb093c4

comment:4 in reply to: ↑ 3 Changed 4 years ago by ubitux

Replying to cehoyos:

Regression since fdb093c4

Yes, and probably lies in ff_vp9_ipred_vl_4x4_ssse3

comment:5 Changed 4 years ago by ubitux

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Ronald S. Bultje in 385a3420d1da2f6812dda56750b41edd469c6079

Note: See TracTickets for help on using tickets.