Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3688 closed defect (duplicate)

Corrupted video when using VDPAU and libavformat

Reported by: jyavenard Owned by:
Priority: normal Component: avformat
Version: unspecified Keywords:
Cc: nfxjfg@googlemail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

When using VDPAU, this particular file doesn't display properly. The picture is mostly black, with some green squares appearing from time to time.
The behaviour changes depending on the VDPAU drivers used (nouveau, nvidia or AMD OSS)

the issue can be reproduced with MPlayer 1.1-4.8 (C) 2000-2012 MPlayer Team (Ubuntu 12.04), when using:
mplayer -vo vdpau -vc ffmpeg12vdpau -demuxer lavf Ondine_clip.mpg

using mplayer's default demuxer, it will play fine

Interestingly, using the new hwaccel VDPAU API with nvidia proprietary drivers will play just fine.
With nouveau, with the hwaccel API it usually crashes and AMD's VDPAU also gives a corrupted video (albeit all green this time).

This issue is seen with some DVDs, other samples are available if required.

Change History (5)

comment:1 Changed 5 years ago by jyavenard

  • Summary changed from Corrupted video when using VDPAU to Corrupted video when using VDPAU and libavformat

comment:2 Changed 5 years ago by gjdfgh

  • Cc nfxjfg@googlemail.com added

Probably related to or duplicate of https://trac.ffmpeg.org/ticket/2915

comment:3 Changed 5 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Same issue as originally reported in ticket #254

comment:4 Changed 5 years ago by jyavenard

ticket #254 is closed... maybe it is worth reopening it for clarity?

comment:5 Changed 5 years ago by jyavenard

duplicate of #2915

Note: See TracTickets for help on using tickets.