Opened 4 years ago

Closed 4 years ago

#3653 closed defect (fixed)

Filtersize of 1 and x86 swscale code

Reported by: kurosu Owned by:
Priority: normal Component: swscale
Version: unspecified Keywords: SSE2
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no


Various values of $CPU crashes or generates incorrect results for make fate-h264-reinit-small_420_8-to-large_444_10 CPUFLAGS=$CPU

$CPU=sse/mmx/mmxext/sse4.2 passes
$CPU=sse2/ssse3 crashes

fault in ff_hscale8to15_X8_sse2
pmaddwd (%r10,%rax,2),%xmm1
p/x $rax = 0x1
p/x $r10+2*$rax : 0x8ba8b42
can't pmaddwd from an unaligned address

$CPU=sse4 doesn't crash but fails

Change History (4)

comment:1 Changed 4 years ago by cehoyos

Could you post a command line that allows to reproduce the crash?

comment:2 Changed 4 years ago by heleppkes

he did:

make fate-h264-reinit-small_420_8-to-large_444_10 CPUFLAGS=sse2

Crashes here as well.
The fact that the other cpu flags don't crash is most likely because there are no optimizations outside of sse2 and ssse3 (and selecting sse4.2 does NOT enable any previous optimizations, for exmaple)

comment:3 Changed 4 years ago by cehoyos

Shouldn't this be "CPUFLAGS=mmx+mmxext+sse+sse2" (or whatever the exact syntax is)?

comment:4 Changed 4 years ago by michael

  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.