Opened 5 years ago

Closed 11 months ago

#3639 closed defect (invalid)

ffmpeg not apply filter to http output stream (to output file is ok)

Reported by: gretchany Owned by:
Priority: normal Component: ffserver
Version: git-master Keywords:
Cc: lars.taeuber@gmx.net Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

CentOS release 6.5 (Final)

ffmpeg version git-2014-05-15-8b96f31
built on May 15 2014 09:47:55 with gcc 4.4.7 (GCC) 20120313 (Red Hat 4.4.7-4)
configuration: --prefix=/root/ffmpeg_build --extra-cflags=-I/root/ffmpeg_build/include --extra-ldflags=-L/root/ffmpeg_build/lib --bindir=/root/bin --extra-libs=-ldl --enable-gpl --enable-nonfree --enable-libfdk_aac --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libfreetype --enable-libfontconfig --enable-avfilter --enable-avresample --enable-pthreads --enable-x11grab --enable-vaapi --enable-vdpau --enable-runtime-cpudetect --enable-fontconfig --enable-pic
libavutil 52. 83.100 / 52. 83.100
libavcodec 55. 61.101 / 55. 61.101
libavformat 55. 37.102 / 55. 37.102
libavdevice 55. 13.101 / 55. 13.101
libavfilter 4. 5.100 / 4. 5.100
libavresample 1. 2. 0 / 1. 2. 0
libswscale 2. 6.100 / 2. 6.100
libswresample 0. 18.100 / 0. 18.100
libpostproc 52. 3.100 / 52. 3.100

*
ffserver.conf
Port 8090
BindAddress? 0.0.0.0
MaxHTTPConnections 2000
MaxClients? 1000
MaxBandwidth? 1000
CustomLog? -
#NoDaemon?
<Feed feed.ffm>

File /tmp/feed.ffm
FileMaxSize? 4M

</Feed>
<Stream live.flv>

Feed feed.ffm
Format swf
VideoCodec? flv
VideoFrameRate? 30
VideoBufferSize? 80000
VideoBitRate? 512
VideoQMin 1
VideoQMax 8
VideoSize? 640x480
PreRoll? 0
NoAudio?

</Stream>
<Stream index.html>

Format status

</Stream>

*
command not correct working
ffmpeg -i http://xxx:xxx@192.168.5.127/mjpg/video.mjpg -vf "drawbox=10:20:200:200:red@0.8" http://localhost:8090/feed.ffm

command correct working:
ffmpeg -i http://xxx:xxx@192.168.5.127/mjpg/video.mjpg -vf "drawbox=10:20:200:200:red@0.8" /home/out.flv

ie filter works fine for output to a file, but does not work when output to a stream
thank you

Change History (8)

comment:1 follow-up: Changed 5 years ago by cehoyos

Is this only reproducible with network input or also with file input?

comment:2 in reply to: ↑ 1 ; follow-up: Changed 5 years ago by gretchany

Replying to cehoyos:

Is this only reproducible with network input or also with file input?

In both cases.
For example:
not working ffmpeg -i /home/video.flv -vf "drawbox=10:20:200:200:red@0.8" http://localhost:8090/feed.ffm
is working ffmpeg -i /home/video.flv -vf "drawbox=10:20:200:200:red@0.8" /home/box.flv

I think it's because of a network video stream output.

comment:3 Changed 5 years ago by cehoyos

But don't you agree that file input would allow us to reproduce the issue?
While http://xxx.xxx is not something that will work for any developer who wants to fix your problem.

comment:4 in reply to: ↑ 2 ; follow-up: Changed 5 years ago by ubitux

Replying to gretchany:

Replying to cehoyos:

Is this only reproducible with network input or also with file input?

In both cases.
For example:
not working ffmpeg -i /home/video.flv -vf "drawbox=10:20:200:200:red@0.8" http://localhost:8090/feed.ffm
is working ffmpeg -i /home/video.flv -vf "drawbox=10:20:200:200:red@0.8" /home/box.flv

I think it's because of a network video stream output.

ffm → ffserver; AFAIK ffserver doesn't support filters. I thought we had a ticket opened for that though.

comment:5 in reply to: ↑ 4 Changed 5 years ago by gretchany

Replying to cehoyos:

But don't you agree that file input would allow us to reproduce the issue?
While http://xxx.xxx is not something that will work for any developer who wants to fix your problem.

For example with working camera
ffmpeg -i rtmp://video1.earthcam.com/earthcamtv/Stream1 http://localhost:8090/feed.ffm

Replying to ubitux:

ffm → ffserver; AFAIK ffserver doesn't support filters. I thought we had a ticket opened for that though.

Thanks for the answer. Can you advise an alternative to ffmpeg to organize OSD (On Screen Display) system in linux

comment:6 Changed 5 years ago by cehoyos

  • Component changed from ffmpeg to ffserver

comment:7 Changed 2 years ago by taeuber

  • Cc lars.taeuber@gmx.net added

why is the component changed to ffserver?
I think the filter should be applied in ffmpeg before sending to ffserver.

I can reproduce this with recent git master (June 2016) with audio filters not being applied.

Thanks

comment:8 Changed 11 months ago by atomnuker

  • Resolution set to invalid
  • Status changed from new to closed

ffserver was removed from git master, closing bug as invalid

Note: See TracTickets for help on using tickets.