Opened 5 years ago

Closed 5 years ago

#3628 closed defect (invalid)

configure's behaviour for --enable-static and --enable-shared seems to be inverted

Reported by: spraff Owned by:
Priority: minor Component: build system
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

This command:

./configure --disable-optimizations --disable-static --enable-shared && make

builds .so files but not .a files, likewise

./configure --disable-optimizations --disable-shared --enable-static && make

builds .a files but not .so files.

This seems to be backwards. Attached is a makefile which demonstrates this in full.

Attachments (1)

Makefile (926 bytes) - added by spraff 5 years ago.
Makefile which builds static and shared versions of libav*

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by spraff

Makefile which builds static and shared versions of libav*

comment:1 Changed 5 years ago by ubitux

.a are static libs, .so are shared ones, so I don't get what you mean.

comment:2 Changed 5 years ago by spraff

  • Resolution set to invalid
  • Status changed from new to closed

Apologies. Brain meltdown.

Note: See TracTickets for help on using tickets.