Opened 5 years ago

Closed 5 years ago

#3626 closed defect (wontfix)

add 'extern "C"' to headers

Reported by: spraff Owned by:
Priority: wish Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Your policy at the moment is to require applications to add 'extern "C"' to their C++ source files: http://trac.ffmpeg.org/wiki/Including%20FFmpeg%20headers%20in%20a%20C%2B%2B%20application

This is silly and annoying.

It is the header file's job to present its interface consistently to applications. decklink_enc.h does this, the other headers should too.

Change History (2)

comment:1 Changed 5 years ago by ubitux

We have about 85 C public headers currently. Am I correct to assume that you are asking us to add a C++ boilerplate cruft for every one of them?

Note that in addition to clutter the public header read by our downstreams, it will suggest that FFmpeg headers are C++ compatible, which is NOT the case because it uses C99 specific features in various places, which are not supported by the C++ language.

comment:2 Changed 5 years ago by cehoyos

  • Keywords headers removed
  • Resolution set to wontfix
  • Status changed from new to closed

The headers are C headers and I believe this documented. If you want to use the library with another compiler language, it is your responsibility to ensure the necessary steps are taken.

Note: See TracTickets for help on using tickets.