Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#3614 closed enhancement (wontfix)

Targa doesn't work with image2pipe

Reported by: Maverick Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: targa
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

I have image001.tga, image002.tga, image003.tga... all being piped into ffmpeg. I'm expecting ffmpeg to accept the tga files and build them into an mp4. However instead it outputs a number of errors and the resulting mp4 is absent or broken.

ffmpeg command and output:
http://pastebin.com/GSBUEbEh

Additional notes:
-If instead of piping the tga files in I add them in sequentially using image2 then there are no errors and the mp4 file is created perfectly.
-Using the image2pipe command (as seen in the pastebin) with jpg files works perfectly as well.

Attachments (4)

ffmpeg_command.txt (130 bytes) - added by Maverick 5 years ago.
command line
ffmpeg_output.txt (11.5 KB) - added by Maverick 5 years ago.
output
3295_0000.zip (1.4 MB) - added by Maverick 5 years ago.
targa0000
3295_0001.zip (1.4 MB) - added by Maverick 5 years ago.
targa0001

Change History (16)

comment:1 Changed 5 years ago by cehoyos

Do the targa files differ in size?

Please understand that using external resources is not ok, please post all information here in the ticket.

comment:2 Changed 5 years ago by Maverick

They do in size, but they all have the same dimensions and bit depth.

comment:3 Changed 5 years ago by cehoyos

  • Component changed from ffmpeg to avcodec
  • Keywords tga added
  • Version changed from unspecified to git-master

Then please attach two targa files that allow to reproduce the issue and post the failing command line including complete, uncut console output here to make this a valid ticket.

Last edited 5 years ago by cehoyos (previous) (diff)

Changed 5 years ago by Maverick

command line

Changed 5 years ago by Maverick

output

comment:4 Changed 5 years ago by Maverick

Sorry about that, I've attached the command line and output text files.

Changed 5 years ago by Maverick

targa0000

Changed 5 years ago by Maverick

targa0001

comment:5 follow-up: Changed 5 years ago by cehoyos

The files you attached have the same size (meaning you can use the image2pipe demuxer option -frame_size to decode them), do you have samples from the same sequence with different file size?

Last edited 5 years ago by cehoyos (previous) (diff)

comment:6 in reply to: ↑ 5 Changed 5 years ago by cehoyos

Replying to cehoyos:

The files you attached have the same size (meaning you can use the rawvideo demuxer option -video_size to decode them)

Sorry for the typo:
It is the image2pipe demuxer option -video_size

comment:7 Changed 5 years ago by cehoyos

And the name of the option is -frame_size...

comment:8 Changed 5 years ago by Maverick

Actually, after checking this out it looks like all the files are the same size on the disk and they are all 1920x1080.

I'm a little confused given the typo with rawvideo/image2pipe; can you give an example command line I should use?

comment:9 Changed 5 years ago by cehoyos

  • Priority changed from normal to wish
  • Reproduced by developer set
  • Resolution set to wontfix
  • Status changed from new to closed
  • Type changed from defect to enhancement
$ ffmpeg -f image2pipe -vcodec targa -frame_size 6220818 -i -

I am not convinced there ever will be a targa parser (which would be necessary to do this without -frame_size).

comment:10 Changed 5 years ago by Maverick

Sorry to ask, but what is the calculation behind the frame_size? I'm not sure how you are getting 6220818. Thanks again.

comment:11 Changed 5 years ago by Maverick

Oh, nevermind. It's just the filesize in bytes. Sorry.

comment:12 Changed 2 years ago by cehoyos

  • Keywords targa added; tga removed
Note: See TracTickets for help on using tickets.