Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3601 closed defect (fixed)

mpeg2video in wtv incorrectly detected as mpeg1video

Reported by: ramitbhalla Owned by:
Priority: important Component: avformat
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug: Ffmpeg is incorrectly reading the video codec and video dimensions.
When one tries to copy remux the file into a MP4 or MKV containers, the resulting file video is unplayable in WMP.

Am not sure if this is due to the incorrect detection of the video details or something else.

How to reproduce:

ffmpeg -i Grimm_KXASDT_2014_04_25_19_57_00.wtv -vcodec copy -acodec copy -map 0:v -map 0:a -sn te
st.mp4
ffmpeg version N-62814-g978c193 Copyright (c) 2000-2014 the FFmpeg developers
  built on Apr 29 2014 16:52:00 with gcc 4.8.0 (GCC)
  configuration: --arch=x86 --target-os=mingw32 --cross-prefix=/Software/ffmpeg/sandbox/mingw-w64-i686/bin/i686-w64-ming
w32- --pkg-config=pkg-config --enable-gpl --enable-libx264 --enable-avisynth --enable-libxvid --enable-libmp3lame --enab
le-version3 --enable-zlib --enable-librtmp --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libopenjpeg
--enable-gnutls --enable-libgsm --enable-libfreetype --enable-libopus --disable-w32threads --enable-frei0r --enable-filt
er=frei0r --enable-libvo-aacenc --enable-bzlib --enable-libxavs --extra-cflags=-DPTW32_STATIC_LIB --enable-libopencore-a
mrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-libschroedinger --enable-libvpx --enable-libilbc --pref
ix=/Software/ffmpeg/sandbox/mingw-w64-i686/i686-w64-mingw32 --enable-static --disable-shared --enable-libsoxr --enable-f
ontconfig --enable-libass --enable-libutvideo --enable-libbluray --enable-iconv --enable-libtwolame --extra-cflags=-DLIB
TWOLAME_STATIC --enable-libzvbi --enable-libcaca --enable-libmodplug --extra-libs=-lstdc++ --extra-libs=-lpng --enable-l
ibvidstab --extra-cflags= --extra-cflags= --enable-nonfree --enable-libfdk-aac --enable-libfaac --enable-runtime-cpudete
ct
  libavutil      52. 80.100 / 52. 80.100
  libavcodec     55. 60.100 / 55. 60.100
  libavformat    55. 37.101 / 55. 37.101
  libavdevice    55. 13.100 / 55. 13.100
  libavfilter     4.  4.100 /  4.  4.100
  libswscale      2.  6.100 /  2.  6.100
  libswresample   0. 18.100 /  0. 18.100
  libpostproc    52.  3.100 / 52.  3.100
[wtv @ 0242e960] truncated file
[wtv @ 0242e960] reported file length (0x1aef76948) exceeds number of available sectors (0xb0000000)
[wtv @ 0242e960] truncated file
    Last message repeated 1 times
[mpeg2video @ 03932ec0] interlaced frame in progressive sequence, ignoring
[mpeg2video @ 03932ec0] invalid frame_pred_frame_dct
[mpeg2video @ 03932ec0] slice below image (30 >= 30)
Input #0, wtv, from 'Grimm_KXASDT_2014_04_25_19_57_00.wtv':
  Metadata:
    WM/MediaClassPrimaryID: db9830bd-3ab3-4fab-8a371a995f7ff74
    WM/MediaClassSecondaryID: ba7f258a-62f7-47a9-b21f4651c42a000
    Title           : Grimm
    WM/SubTitle     : Nobody Knows the Trubel I've Seen
    WM/SubTitleDescription: Nick and Hank investigate when a dangerous suspect leaves a trail of wesen in her wake; Adal
ind forms a dangerous alliance.
    genre           : Drama;General;Series;Sci-Fi/Fantasy
    WM/OriginalReleaseTime: 0
    WM/MediaCredits : David Giuntoli/Russell Hornsby/Reggie Lee/Silas Weir Mitchell/Sasha Roiz/Bitsie Tulloch/Bree Turne
r/Claire Coffee;;;Jacqueline Toboni/C. Thomas Howell/Alexis Denisof/Philip Anthony Rodriguez
    service_provider: KXASDT
    service_name    : KXASDT (KXAS-DT)
    WM/MediaNetworkAffiliation: NBC Affiliate
    WM/MediaOriginalChannel: 5
    WM/MediaOriginalChannelSubNumber: 1
    WM/MediaOriginalBroadcastDateTime: 2014-04-25T05:00:00Z
    WM/MediaOriginalRunTime: 40151865409
    WM/MediaIsStereo: true
    WM/MediaIsRepeat: false
    WM/MediaIsLive  : false
    WM/MediaIsTape  : false
    WM/MediaIsDelay : false
    WM/MediaIsSubtitled: false
    WM/MediaIsMovie : false
    WM/MediaIsPremiere: false
    WM/MediaIsFinale: false
    WM/MediaIsSAP   : false
    WM/MediaIsSport : false
    WM/ParentalRating: TV-14
    WM/Provider     : MediaCenterDefault
    WM/VideoClosedCaptioning: true
    WM/WMRVEncodeTime: 2014-04-26 00:57:04
    WM/WMRVSeriesUID: !MCSeries!258649334
    WM/WMRVServiceID: !MCService!28457086
    WM/WMRVProgramID: !MCProgram!299207826
    WM/WMRVRequestID: 0
    WM/WMRVScheduleItemID: 0
    WM/WMRVQuality  : 3
    WM/WMRVOriginalSoftPrePadding: 480
    WM/WMRVOriginalSoftPostPadding: 180
    WM/WMRVHardPrePadding: 4294966996
    WM/WMRVHardPostPadding: 0
    WM/WMRVATSCContent: true
    WM/WMRVDTVContent: true
    WM/WMRVHDContent: true
    Duration        : 40159686774
    WM/WMRVEndTime  : 2014-04-26 02:04:00
    WM/WMRVBitrate  : 14.404455
    WM/WMRVKeepUntil: 0
    WM/WMRVActualSoftPrePadding: 475
    WM/WMRVActualSoftPostPadding: 180
    WM/WMRVContentProtected: false
    WM/WMRVContentProtectedPercent: 0
    WM/WMRVExpirationSpan: 9223372036854775807
    WM/WMRVInBandRatingSystem: 255
    WM/WMRVInBandRatingLevel: 255
    WM/WMRVInBandRatingAttributes: 0
    WM/WMRVWatched  : false
  Duration: 00:25:35.50, start: 3.128033, bitrate: 546 kb/s
    Stream #0:0[0x16](eng): Audio: ac3, 48000 Hz, 5.1(side), fltp, 384 kb/s
    Stream #0:1[0x17](spa): Audio: ac3, 48000 Hz, stereo, fltp, 192 kb/s
    Stream #0:2[0x18]: Video: mpeg1video, yuv420p(tv), 704x480 [SAR 64:45 DAR 1408:675], 12000 kb/s, 59.94 tbr, 10000k t
bn, 59.94 tbc
    Stream #0:3[0x19]: Subtitle: eia_608
File 'test.mp4' already exists. Overwrite ? [y/N] y
[mp4 @ 03a33140] track 1: codec frame size is not set
[mp4 @ 03a33140] track 2: codec frame size is not set
Output #0, mp4, to 'test.mp4':
  Metadata:
    WM/MediaClassPrimaryID: db9830bd-3ab3-4fab-8a371a995f7ff74
    WM/MediaClassSecondaryID: ba7f258a-62f7-47a9-b21f4651c42a000
    Title           : Grimm
    WM/SubTitle     : Nobody Knows the Trubel I've Seen
    WM/SubTitleDescription: Nick and Hank investigate when a dangerous suspect leaves a trail of wesen in her wake; Adal
ind forms a dangerous alliance.
    genre           : Drama;General;Series;Sci-Fi/Fantasy
    WM/OriginalReleaseTime: 0
    WM/MediaCredits : David Giuntoli/Russell Hornsby/Reggie Lee/Silas Weir Mitchell/Sasha Roiz/Bitsie Tulloch/Bree Turne
r/Claire Coffee;;;Jacqueline Toboni/C. Thomas Howell/Alexis Denisof/Philip Anthony Rodriguez
    service_provider: KXASDT
    service_name    : KXASDT (KXAS-DT)
    WM/MediaNetworkAffiliation: NBC Affiliate
    WM/MediaOriginalChannel: 5
    WM/MediaOriginalChannelSubNumber: 1
    WM/MediaOriginalBroadcastDateTime: 2014-04-25T05:00:00Z
    WM/MediaOriginalRunTime: 40151865409
    WM/MediaIsStereo: true
    WM/MediaIsRepeat: false
    WM/MediaIsLive  : false
    WM/MediaIsTape  : false
    WM/MediaIsDelay : false
    WM/MediaIsSubtitled: false
    WM/MediaIsMovie : false
    WM/MediaIsPremiere: false
    WM/MediaIsFinale: false
    WM/MediaIsSAP   : false
    WM/MediaIsSport : false
    WM/ParentalRating: TV-14
    WM/Provider     : MediaCenterDefault
    WM/VideoClosedCaptioning: true
    WM/WMRVEncodeTime: 2014-04-26 00:57:04
    WM/WMRVSeriesUID: !MCSeries!258649334
    WM/WMRVServiceID: !MCService!28457086
    WM/WMRVProgramID: !MCProgram!299207826
    WM/WMRVRequestID: 0
    WM/WMRVScheduleItemID: 0
    WM/WMRVQuality  : 3
    WM/WMRVOriginalSoftPrePadding: 480
    WM/WMRVOriginalSoftPostPadding: 180
    WM/WMRVHardPrePadding: 4294966996
    WM/WMRVHardPostPadding: 0
    WM/WMRVATSCContent: true
    WM/WMRVDTVContent: true
    WM/WMRVHDContent: true
    Duration        : 40159686774
    WM/WMRVEndTime  : 2014-04-26 02:04:00
    WM/WMRVBitrate  : 14.404455
    WM/WMRVKeepUntil: 0
    WM/WMRVActualSoftPrePadding: 475
    WM/WMRVActualSoftPostPadding: 180
    WM/WMRVContentProtected: false
    WM/WMRVContentProtectedPercent: 0
    WM/WMRVExpirationSpan: 9223372036854775807
    WM/WMRVInBandRatingSystem: 255
    WM/WMRVInBandRatingLevel: 255
    WM/WMRVInBandRatingAttributes: 0
    WM/WMRVWatched  : false
    encoder         : Lavf55.37.101
    Stream #0:0: Video: mpeg1video (j[0][0][0] / 0x006A), yuv420p, 704x480 [SAR 64:45 DAR 1408:675], q=2-31, 12000 kb/s,
 10000k tbn, 10000k tbc
    Stream #0:1(eng): Audio: ac3 ([165][0][0][0] / 0x00A5), 48000 Hz, 5.1(side), 384 kb/s
    Stream #0:2(spa): Audio: ac3 ([165][0][0][0] / 0x00A5), 48000 Hz, stereo, 192 kb/s
Stream mapping:
  Stream #0:2 -> #0:0 (copy)
  Stream #0:0 -> #0:1 (copy)
  Stream #0:1 -> #0:2 (copy)
Press [q] to stop, [?] for help
frame= 1670 fps=0.0 q=-1.0 Lsize=   99124kB time=00:00:56.92 bitrate=14265.7kbits/s
video:95095kB audio:3982kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.047069%}}}

Attaching a 2MB segment of the above file for analysis.

Attachments (1)

#3601.wtv (2.0 MB) - added by ramitbhalla 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by ramitbhalla

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

The video codec is mpeg2video and is written as mpeg2video in the file, the incorrect codec detection is a regression since f3743901 (possibly related to ticket #3548).

comment:2 Changed 5 years ago by cehoyos

  • Summary changed from ffmpeg reading WTV video codec, size incorrectly and creating unplayable MP4/MKV on stream copying to mpeg2video in wtv incorrectly detected as mpeg1video

comment:3 Changed 5 years ago by ramitbhalla

The video size is also reported incorrectly. It is 1080p

comment:4 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Peter Ross in be098f62 - thank you for the report!

comment:5 follow-up: Changed 5 years ago by ramitbhalla

Thanks, does this also fix the incorrect resolution issue?

comment:6 in reply to: ↑ 5 Changed 5 years ago by pross

Replying to ramitbhalla:

Thanks, does this also fix the incorrect resolution issue?

Yes

Note: See TracTickets for help on using tickets.