Opened 5 years ago

Closed 5 years ago

#3580 closed defect (fixed)

Compile ffplay.c with Visual Studio

Reported by: achristensen Owned by:
Priority: normal Component: ffplay
Version: git-master Keywords: msvc
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I have a successful build of ffplay using Visual Studio 2013. I linked with today's libraries from http://ffmpeg.zeranoe.com/builds/ and I needed these two changes to make it compile. The first is to avoid what seems like a bug in Visual Studio to avoid this error:

error C2440: 'initializing' : cannot convert from 'AVRational' to 'int'

I've attached a proposed patch.

Attachments (1)

patch (1.2 KB) - added by achristensen 5 years ago.
patch

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by achristensen

patch

comment:1 Changed 5 years ago by cehoyos

  • Keywords windows removed

Patches are generally ignored on this bug tracker, please send them - made with git format-patch - to the ffmpeg-devel mailing list where they can be reviewed.

comment:2 Changed 5 years ago by cehoyos

  • Keywords msvc added
  • Resolution set to fixed
  • Status changed from new to closed
  • Type changed from enhancement to defect

This should be fixed since e1169775 - thank you for the report!

Note: See TracTickets for help on using tickets.