Opened 6 years ago

Closed 5 years ago

#3450 closed enhancement (duplicate)

Unsupported mxf file containing dnxhd video

Reported by: cehoyos Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: AVID mxf dnxhd
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

http://thread.gmane.org/gmane.comp.video.ffmpeg.user/50830/focus=50888
A user uploaded a mxf file containing dnxhd video that the mxf demuxer cannot read.

$ ffmpeg -loglevel 99 -i WriteAvidMXFgenerated/5502_0010_v1.mxf
ffmpeg version N-61253-g27b4d15 Copyright (c) 2000-2014 the FFmpeg developers
  built on Mar 10 2014 13:23:55 with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl
  libavutil      52. 66.101 / 52. 66.101
  libavcodec     55. 52.102 / 55. 52.102
  libavformat    55. 34.100 / 55. 34.100
  libavdevice    55. 11.100 / 55. 11.100
  libavfilter     4.  3.100 /  4.  3.100
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 18.100 /  0. 18.100
  libpostproc    52.  3.100 / 52.  3.100
Splitting the commandline.
Reading option '-loglevel' ... matched as option 'loglevel' (set logging level) with argument '99'.
Reading option '-i' ... matched as input file with argument 'WriteAvidMXFgenerated/5502_0010_v1.mxf'.
Finished splitting the commandline.
Parsing a group of options: global .
Applying option loglevel (set logging level) with argument 99.
Successfully parsed a group of options.
Parsing a group of options: input file WriteAvidMXFgenerated/5502_0010_v1.mxf.
Successfully parsed a group of options.
Opening an input file: WriteAvidMXFgenerated/5502_0010_v1.mxf.
[mxf @ 0x32aa100] Format mxf probed with size=2048 and score=100
[mxf @ 0x32aa100] none: Universal Label: 060e2b34.0401.0101.0e040201.02040100
[mxf @ 0x32aa100] Field dominance 0 support is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
[mxf @ 0x32aa100] If you want to help, upload a sample of this file to ftp://upload.ffmpeg.org/MPlayer/incoming/ and contact the ffmpeg-devel mailing list.
[mxf @ 0x32aa100] Before avformat_find_stream_info() pos: 393191 bytes read:230022 seeks:7
[mxf @ 0x32aa100] parser not found for codec none, packets or times may be invalid.
    Last message repeated 1 times
[mxf @ 0x32aa100] Probe buffer size limit of 5000000 bytes reached
[mxf @ 0x32aa100] Could not find codec parameters for stream 0 (Video: none, 1920x1080, 1/25): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mxf @ 0x32aa100] After avformat_find_stream_info() pos: 5849088 bytes read:5685919 seeks:7 frames:9
WriteAvidMXFgenerated/5502_0010_v1.mxf: could not find codec parameters

Change History (3)

comment:2 Changed 6 years ago by cehoyos

Maybe a duplicate of ticket #1554.

comment:3 Changed 5 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Indeed a duplicate of ticket #1554, fixed by Mark Reid in 882fb53c

Note: See TracTickets for help on using tickets.