Opened 6 years ago

Closed 6 years ago

#3411 closed defect (duplicate)

vtag.fourcc can no longer be set in mov multiplexer

Reported by: ortoni Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


Previous versions (e.g. v 1.1) of ffmpeg allowed the 'fourcc' to be set for IMX using "-vtag mx3p". This sets the "type" field in the stsd atom in the mov.

v 2.1 ffmpeg and above does not set this information but does not complain about the "-vtag mx3p" option:

ffmpeg -i work.m2v -i stereo.wav -vcodec copy -acodec copy -vtag mx3p -r 25

ffmpeg version N-60835-ga3a4d07 Copyright (c) 2000-2014 the FFmpeg developers

built on Feb 22 2014 22:01:54 with gcc 4.8.2 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-

bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enabl
e-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libm
odplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libope
njpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libsp
eex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-li
bvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-li
bx265 --enable-libxavs --enable-libxvid --enable-zlib

libavutil 52. 65.100 / 52. 65.100
libavcodec 55. 52.102 / 55. 52.102
libavformat 55. 33.100 / 55. 33.100
libavdevice 55. 10.100 / 55. 10.100
libavfilter 4. 1.103 / 4. 1.103
libswscale 2. 5.101 / 2. 5.101
libswresample 0. 17.104 / 0. 17.104
libpostproc 52. 3.100 / 52. 3.100

Input #0, mpegvideo, from 'c:\tmpdir\fixed.m2v':

Duration: N/A, bitrate: N/A

Stream #0:0: Video: mpeg2video (4:2:2), yuv422p(tv), 720x608 [SAR 152:135 DAR 4:3], max. 300

00 kb/s, 25 fps, 25 tbr, 1200k tbn, 50 tbc
Guessed Channel Layout for Input Stream #1.0 : stereo
Input #1, wav, from 'c:\tmpdir\stereo.wav':

Duration: 00:00:05.08, bitrate: 1536 kb/s

Stream #1:0: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 48000 Hz, stereo, s16, 1536 kb/s

Output #0, mov, to 'c:\tmpdir\':


encoder : Lavf55.33.100
Stream #0:0: Video: mpeg2video (mx3p / 0x7033786D), yuv422p, 720x608 [SAR 152:135 DAR 4:3],

q=2-31, max. 30000 kb/s, 25 fps, 12800 tbn, 25 tbc

Stream #0:1: Audio: pcm_s16le (sowt / 0x74776F73), 48000 Hz, stereo, 1536 kb/s

Stream mapping:

Stream #0:0 -> #0:0 (copy)
Stream #1:0 -> #0:1 (copy)

Press [q] to stop, ? for help
frame= 125 fps=0.0 q=-1.0 Lsize= 18490kB time=00:00:05.08 bitrate=29817.6kbits/s
video:17535kB audio:952kB subtitle:0 data:0 global headers:0kB muxing overhead 0.017215%

stsd atom reports type = m2v1 instead of mx3p.

Input files are correct types for this output format, and the same commands and files with v1.1 ffmpeg work correctly

I also tried video file alone:
ffmpeg -i work.m2v -vtag mx3p -r25

with same result

As ever, thank you ffmpeg developers!

Change History (3)

comment:1 follow-up: Changed 6 years ago by ortoni

This may be related to ticket #3351 - I notice the output of the IMX encoding reported was type "m2v1" also instead of the vtag "mx5p" in the command string.

Last edited 6 years ago by ortoni (previous) (diff)

comment:2 in reply to: ↑ 1 Changed 6 years ago by cehoyos

Replying to ortoni:

This may be related to ticket #3351

Could you do the tests requested there?

comment:3 Changed 6 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

I believe this was a duplicate of ticket #3351
Please reopen this ticket if it is still reproducible with current FFmpeg git head.

Note: See TracTickets for help on using tickets.