Opened 6 years ago

Closed 5 years ago

#3367 closed defect (fixed)

vlc2.1.2, crash when using hw accel vdpau

Reported by: promeneur Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: videolan
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Vlc 2.1.2 and all the libraries i installed come from packman .
Nvidia 331.38
libavcodec52 0.7.16
libavcodec55 2.1.2

Hello

Thanks for your all packets
but there is a pb with VLC using codecs

I report the pb to vlc .

Summary : using hw accel (vaapi or vdpau) with vlc leads to a crash
Answer from vlc team : this is a libavcodec pb not a vlc pb .

See the complete report with the track of crash and the explanation from vlc : https://trac.videolan.org/vlc/ticket/10276

i joined a new full bt

Attachments (1)

btfull (7.3 KB) - added by promeneur 6 years ago.
full bt

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by promeneur

full bt

comment:1 Changed 6 years ago by cehoyos

What is VDPAU-related about this crash? The backtrace indicates you are using VA-API or do I miss something?

comment:2 Changed 6 years ago by cehoyos

And please install the vlc-debug packages to produce a useful backtrace and add the missing information (disassembly and register content), see http://ffmpeg.org/bugreports.html

comment:3 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords videolan added
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from unspecified to git-master

I suspect this issue is fixed since a22907e9

Note: See TracTickets for help on using tickets.