Opened 6 years ago

Closed 5 years ago

#3299 closed enhancement (fixed)

Add the possibility to fade in / fade out text with drawtext

Reported by: slhck Owned by:
Priority: wish Component: avfilter
Version: unspecified Keywords: drawtext
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

The drawtext filter currently does not allow fading in or fading out of text. It'd be a useful feature to have, but at the moment, I think this can only be achieved by rendering ASS effects, pre-generating the subtitle text with ImageMagick? (or something similar), or a super complex blend filter.

I could imagine that this is easily implemented with two additional options:

  • fade in duration
  • fade out duration

Change History (1)

comment:1 Changed 5 years ago by saste

  • Resolution set to fixed
  • Status changed from new to closed

This is possible since commit:

commit e9ff5df0b53076636082412f06bdd3b6aaa2b607
Author: Andrey Utkin <andrey.krieger.utkin@gmail.com>
Date:   Fri Jul 4 21:54:53 2014 +0300

    lavfi/drawtext: add fontcolor_expr option
    
    Allow to dynamically evaluate the font color.
    
    Signed-off-by: Stefano Sabatini <stefasab@gmail.com>

You need to set an expression for the fontcolor alpha component.

Note: See TracTickets for help on using tickets.