Opened 6 years ago

Closed 6 years ago

#3295 closed defect (duplicate)

Output option '-to time' produces unespected results.

Reported by: LeSna Owned by:
Priority: normal Component: ffmpeg
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description (last modified by cehoyos)

Summary of the bug: '-to time' option used with -ss option produces unespected results.
How to reproduce: -ss 10 -i input -to 20 output

% ffmpeg -i input ... output
ffmpeg version: N-58338-gfb7d70c
built on: Nov 21 2013 20:08:44 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil      52. 53.100 / 52. 53.100
  libavcodec     55. 44.100 / 55. 44.100
  libavformat    55. 21.100 / 55. 21.100
  libavdevice    55.  5.100 / 55.  5.100
  libavfilter     3. 91.100 /  3. 91.100
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100

#2355 ticket is marked as 'fixed' but #2746 still is 'new' then I marked Priority as 'Important'
Check additionally please another combinations -ss and -to options, i.e.
-ss 10 - i input -ss 1 -to 20 output

Change History (1)

comment:1 Changed 6 years ago by cehoyos

  • Description modified (diff)
  • Keywords record duration removed
  • Priority changed from important to normal
  • Resolution set to duplicate
  • Status changed from new to closed

If this is not a duplicate of ticket #2746, please add the failing command line together with the complete, uncut console output and reopen the ticket.

Note: See TracTickets for help on using tickets.