Opened 6 years ago

Closed 6 years ago

Last modified 8 months ago

#3158 closed defect (invalid)

FFmpeg fails to encode mono audio using libfdk-aac and a variable bitrate.

Reported by: lkiesow Owned by:
Priority: normal Component: avcodec
Version: unspecified Keywords: libfdk-aac
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

Summary of the bug:

FFmpeg fails to encode mono audio using libfdk-aac and a variable bitrate.

  • Mono and fixed bitrate works
  • Stereo and variable bitrate works

How to reproduce:

% fmpeg -i test.wav -c:a libfdk_aac -ac 1 -vbr 3 test.aac

FFmpeg-Version used: 2.1

Test media (~600kb):

http://repo.virtuos.uos.de/ffmpeg-libfdk_aac-bug/test.wav

Log output:

http://repo.virtuos.uos.de/ffmpeg-libfdk_aac-bug/ffmpeg-20131118-104646.log.txt

Attachments (2)

ffmpeg-20131118-104646.log (5.8 KB) - added by lkiesow 6 years ago.
FFmpeg log
test.wav (625.1 KB) - added by lkiesow 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by lkiesow

FFmpeg log

Changed 6 years ago by lkiesow

comment:1 Changed 6 years ago by cehoyos

  • Component changed from FFmpeg to avcodec
  • Keywords libfdk_aac added; audio Mono AAC removed

Is this reproducible with current FFmpeg git head?

comment:2 Changed 6 years ago by saste

The following command works:

ffmpeg -i test.wav -c:a libfdk_aac -ar 22050 -ac 1 -vbr 3 -y test.aac

Seems a problem with the libfdk_aac library.

comment:3 Changed 6 years ago by saste

  • Analyzed by developer set
  • Reproduced by developer set
  • Resolution set to invalid
  • Status changed from new to closed

I got confirmation that the issue is related to libfdk-aac functionality status. In short VBR encoding in libfdk-aac is experimental and only works with some parameter combinations (as shown in the log).

I stressed that in our docs. Closing the ticket since the issue is not related to our codebase.

comment:4 Changed 8 months ago by cehoyos

  • Keywords libfdk-aac added; libfdk_aac removed
  • Version set to unspecified
Note: See TracTickets for help on using tickets.