Opened 6 years ago

Closed 6 years ago

#3092 closed defect (duplicate)

[swscaler @ 0128b200] deprecated pixel format used, make sure you did set range

Reported by: ahsan Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

I build the filtering_video example code using latest
ffmpeg-20131026-git-c78a416-win32-dev version of ffmpeg on windows 7 platform using Micro Soft Visual Studio 2012.

When i try to use .jpg image with this example i get following message

============================================================
[swscaler @ 0128b200] deprecated pixel format used, make sure you did set range
============================================================

during the processing and the example crashes at the "av_frame_free(&frame);" call in main with the message
==============================================================
First-chance exception at 0x53567E74 (avutil-52.dll) in Sharpness.exe: 0xC0000005: Access violation reading location 0xF666F656.
==============================================================

Please let me know if there is something else which needs to be performed to avoid this crash

How to reproduce:

% filtering_video.exe BryceCanyon4.jpg

ffmpeg version -- ffmpeg-20131026-git-c78a416-win32-dev
built on -- Windows 7 MSVC Express 2012

Please let me know if there is a work around to avoid this memory crash issue?

Attachments (1)

BryceCanyon4--.jpg (997.9 KB) - added by ahsan 6 years ago.
1080p jpeg file

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by ahsan

1080p jpeg file

comment:1 Changed 6 years ago by ahsan

with the 1080p jpg file attached with this mail memory error message is
===============================================================================
First-chance exception at 0x53387E74 (avutil-52.dll) in Sharpness.exe: 0xC0000005: Access violation reading location 0xF666F656.
===============================================================================

memory crash message in the original bug is for 4k version of jpg file, i could not attach that file with the bug as its size is around 4k.

comment:2 Changed 6 years ago by cehoyos

Is the crash reproducible with the file you attached to this ticket? If not, please upload the needed sample to http://www1.datafilehost.com or read http://ffmpeg.org/bugreports.html

comment:3 Changed 6 years ago by ubitux

  • Resolution set to duplicate
  • Status changed from new to closed

Probably a duplicate of #3093

Note: See TracTickets for help on using tickets.