Opened 4 years ago

Closed 4 years ago

#3057 closed enhancement (fixed)

Set loglevel for written log file

Reported by: spookybathtub Owned by:
Priority: wish Component: ffmpeg
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I would like to suppress info in the console, and write a logfile with -loglevel info. But when the -report option is specified, the written log file always uses the verbose log level, and that's more detail than I want.

$ ffmpeg -loglevel warning -stats -report -i 1.mov 1.mp4
No pixel format specified, yuv422p for H.264 encoding chosen.
Use -pix_fmt yuv420p for compatibility with outdated media players.
$ Lsize=   14492kB time=00:00:49.85 bitrate=2381.2kbits/s

Attachments (1)

ffmpeg-20131018-173820.log (137.6 KB) - added by spookybathtub 4 years ago.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by spookybathtub

comment:1 Changed 4 years ago by cehoyos

  • Component changed from undetermined to FFmpeg
  • Priority changed from normal to wish
  • Status changed from new to open

comment:2 Changed 4 years ago by cehoyos

Afair, the reason for the -report option was to simplify bug reports. If you want to use -loglevel for output to a textfile, redirect your console to a file.

comment:3 Changed 4 years ago by spookybathtub

But that will completely suppress console output. When ffmpeg is run in a shell script to batch process files, in a supervised environment, it's very useful to have the single line stats readout so the user has some form of progress display.

comment:4 Changed 4 years ago by spookybathtub

The documentation for the FFREPORT variable says it uses a ’:’-separated key=value sequence, but file is the only key defined. Would it be easy to add another key for loglevel there?

comment:6 Changed 4 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.