Opened 6 years ago

Closed 6 years ago

#3054 closed defect (fixed)

uninstall-man uses invalid paths and fails to remove manpages

Reported by: jamal Owned by:
Priority: important Component: build system
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

jamrial@GentooVM ~/build $ make uninstall-man V=1
rm -f "/usr/local/share/man/man1/"doc/ffmpeg.1 "/usr/local/share/man/man1/"doc/ffprobe.1 "/usr/local/share/man/man1/"doc/ffserver.1 "/usr/local/share/man/man1/"doc/ffmpeg-all.1 "/usr/local/share/man/man1/"doc/ffprobe-all.1 "/usr/local/share/man/man1/"doc/ffserver-all.1 "/usr/local/share/man/man1/"doc/ffmpeg-utils.1 "/usr/local/share/man/man1/"doc/ffmpeg-scaler.1 "/usr/local/share/man/man1/"doc/ffmpeg-resampler.1 "/usr/local/share/man/man1/"doc/ffmpeg-codecs.1 "/usr/local/share/man/man1/"doc/ffmpeg-bitstream-filters.1 "/usr/local/share/man/man1/"doc/ffmpeg-formats.1 "/usr/local/share/man/man1/"doc/ffmpeg-protocols.1 "/usr/local/share/man/man1/"doc/ffmpeg-devices.1 "/usr/local/share/man/man1/"doc/ffmpeg-filters.1
rm -f "/usr/local/share/man/man3/"doc/libavutil.3 "/usr/local/share/man/man3/"doc/libswscale.3 "/usr/local/share/man/man3/"doc/libswresample.3 "/usr/local/share/man/man3/"doc/libavcodec.3 "/usr/local/share/man/man3/"doc/libavformat.3 "/usr/local/share/man/man3/"doc/libavdevice.3 "/usr/local/share/man/man3/"doc/libavfilter.3

The quotes don't cover the full path, and a stray doc/ is added as well, which is valid for the build folder but not the system folder.

The rm commands don't return any kind of error or warning, so the user never notices the manpages weren't removed.

Change History (2)

comment:1 Changed 6 years ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open

The quotes work fine here and are not a regression, "doc" is a regression since 90cb081f

comment:2 Changed 6 years ago by saste

  • Analyzed by developer set
  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed in:

commit af1c5388501e80e6d92704bb70610998226e5e51
Author: Stefano Sabatini <stefasab@gmail.com>
Date:   Thu Oct 24 21:14:55 2013 +0200

    doc/Makefile: fix man pages uninstall path
    
    Fix trac ticket #3054.
Note: See TracTickets for help on using tickets.